Bug 205772 - Enhancement: enable "ldap_sasl_bind" feature for php-ldap
Enhancement: enable "ldap_sasl_bind" feature for php-ldap
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Joe Orton
David Lawrence
: EasyFix, FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-08 09:01 EDT by Dmitry Butskoy
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 5.2.1-5
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-29 10:36:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitry Butskoy 2006-09-08 09:01:55 EDT
Consider a possibility to provide SASL authentication for PHP ldap module,
i.e. use "--with-ldap-sasl" when configure. With this option, an additional
function "ldap_sasl_bind" will appear.

Note, that the current ldap.so module already depends on libsasl2 (see ldd
/usr/lib/php/modules/ldap.so), because ldap libraries already compiled with sasl
support. It means that nothing too big will be added anyway...
Comment 1 Joe Orton 2007-03-29 10:36:37 EDT
This is done in Raw Hide now; thanks for the suggestion.

Note You need to log in before you can comment on or make changes to this bug.