Bug 205786 - deskbar-applet hangs gnome-pannel
deskbar-applet hangs gnome-pannel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: deskbar-applet (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Michael J Knox
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE7Target
  Show dependency treegraph
 
Reported: 2006-09-08 10:57 EDT by Russell Harrison
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.16.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-05 04:26:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Some basic debugging. (2.19 KB, text/plain)
2006-09-08 10:57 EDT, Russell Harrison
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 354978 None None None Never

  None (edit)
Description Russell Harrison 2006-09-08 10:57:57 EDT
Description of problem:
For the past few weeks (I finally figured it out) the deskbar-applet has been
hanging my gnome-panel.  Whenever gnome-panel needs to update for some reason it
hangs apparently because its waiting on the deskbar-applet.  

This causes a shutdown from the interface to take as long as 5 minutes before it
actually occurs.  If I switch to another terminal and give the python process
for deskbar a kill -3 the shutdown begins immediately.

Version-Release number of selected component (if applicable):

deskbar-applet-2.14.0-2.fc5

How reproducible:

I'm pretty sure this is related to beagle and evolution-sharp somehow.  I think
this really started happening around one of the evolution updates.

Steps to Reproduce:

Place the deskbar-applet in your panel.  Let beagle go and get itself in a bind.
 If the applet is gray you know its hung.  Then if you do anything to the panel
it'll hang until you kill off deskbar.

I'm attaching some commands I ran to give a little more information.  Let me
know if you need anything else
Comment 1 Russell Harrison 2006-09-08 10:57:58 EDT
Created attachment 135850 [details]
Some basic debugging.
Comment 2 Michael J Knox 2006-09-08 18:53:11 EDT
I am currently rolling the current release. Hopefully today or tomorrow. Lets
see if that corrects the issue as suggested in the gnome BZ report. 
Comment 3 Luke Macken 2006-10-01 18:10:33 EDT
2.16.0 is currently being built for devel.  Once it is available, please see if
this bug can be reproduced.
Comment 4 Russell Harrison 2006-11-01 03:08:16 EST
I have not seen the same problem in FC6 yet.  I'm still trying to determine if
my beagle indexes are getting built properlly, but I think this problem may be
fixed here.
Comment 5 Luke Macken 2006-11-05 04:26:14 EST
Thanks.  Please re-open if you encounter this again.

Note You need to log in before you can comment on or make changes to this bug.