Bug 205822 - kernel-devel: bttvp.h requires non-existent header (btcx-risc.h)
kernel-devel: bttvp.h requires non-existent header (btcx-risc.h)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-08 14:26 EDT by Raoul
Modified: 2015-01-04 17:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-10 23:29:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raoul 2006-09-08 14:26:50 EDT
Description of problem:
The drivers/media/video/bt8xx/bttvp.h header contains the statement:
#include "btcx-risc.h"
btcx-risc.h does not exist in the same directory, but in the parent, so kernel
modules that require bttvp.h fail to compile.

Version-Release number of selected component (if applicable):
2.6.17-1.2174_FC5 and generally in 2.6.17 kernels where the bt8xx files where
re-organized.

How reproducible:
Example: I could not build the LIRC module lirc_gpio, even after correcting the
paths to bttv.h and bttvp.h in its source. The module could be compiled after i
copied btcx-risc.h into the drivers/media/video/bt8xx/ directory.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Dave Jones 2006-09-10 23:29:56 EDT
from that header file..

    bttv's *private* header file  --  nobody other than bttv itself
    should ever include this file.

lirc shouldn't be using this. If this was meant to be used by out of tree
modules, it would be in include/
Comment 2 Raoul 2006-09-11 10:41:04 EDT
So, lirc_gpio source is the exclusive cause of the problem. I thought otherwise
because the lirc module could be compiled after I copied the "btcx-risc.h"
header into the new bt8xx directory in the kernel tree and I thought that the
problem was in the bttvp.h header.

Thanks for clearing this out because I was only trying to guess, taking into
account my very little knowledge of C.

Also, I made a mistake in the bug title. This problem actually *is not* related
to kernel-devel. The bttv related headers are completely missing from this
package. I used the kernel SRPM.

Note You need to log in before you can comment on or make changes to this bug.