Bug 205825 - Accessibility problems with themed greeters
Summary: Accessibility problems with themed greeters
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm   
(Show other bugs)
Version: 5
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-08 18:55 UTC by Peter Parente
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-08 19:50:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 355005 None None None Never

Description Peter Parente 2006-09-08 18:55:24 UTC
The Fedora Bubbles and Bluecurve themes for the gdm greeter have accessibility
problems. More specifically, the username/password text field does not have the
ATK "labelled by" relation making it difficult for a screen reader to announce
the purpose of the text box to a blind user.

The plain, unthemed greeter correctly provides this relation. But since picking
an login theme requires admin priviledges, switching to the plain greeter is not
a solution for unpriviledged users.

Contact me if you need help using ATK to correct this problem.

Comment 1 Peter Parente 2006-09-08 19:50:52 UTC
On second look, this is problem probably exists not in the theme, but in the
gdmgreeter application. I'll close this bug and push for a correction upstream
at gnome.org.


Note You need to log in before you can comment on or make changes to this bug.