Bug 2058270 - CCO mint mode will not work for Azure after sunsetting of Active Directory Graph API
Summary: CCO mint mode will not work for Azure after sunsetting of Active Directory Gr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Credential Operator
Version: 4.8
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.8.z
Assignee: Eric Fried
QA Contact: Jianping SHu
URL:
Whiteboard:
Depends On: 2055821
Blocks: 2064428
TreeView+ depends on / blocked
 
Reported: 2022-02-24 15:45 UTC by Eric Fried
Modified: 2022-03-21 18:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-16 11:30:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cloud-credential-operator pull 454 0 None open Bug 2058270: Remove Azure mint mode support as Active Directory Graph API will be sunset 2022-02-26 06:08:51 UTC
Red Hat Bugzilla 2055821 1 unspecified CLOSED CCO mint mode will not work for Azure after sunsetting of Active Directory Graph API 2022-03-16 11:39:33 UTC
Red Hat Product Errata RHBA-2022:0795 0 None None None 2022-03-16 11:30:24 UTC

Description Eric Fried 2022-02-24 15:45:38 UTC
Description of problem:
(copied from https://bugzilla.redhat.com/show_bug.cgi?id=2055821)

With the upcoming sunset of the Azure AD Graph API on June 30 2022, CCO will no longer be able to reliably create ServicePrincipals while processing a CredentialsRequest in Mint mode. We cannot transition to a new API yet as Go SDK support is not production ready.


Version-Release number of selected component (if applicable):
4.8

How reproducible:
Always (after June 30 2022)

Steps to Reproduce:
1. Install OpenShift cluster on Azure in Mint mode after June 30 2022

Actual results:
CCO will fail to provision Credentials Request and cluster install will not succeed

Expected results:
CCO should be able to provision Credentials Request and cluster install should succeed

Additional info:

Link to azure announcement indicating that Azure AD Graph API will be sunset - https://techcommunity.microsoft.com/t5/azure-active-directory-identity/update-your-applications-to-use-microsoft-authentication-library/ba-p/1257363

Comment 2 Jianping SHu 2022-03-02 02:06:48 UTC
Verified as in the PR.
https://github.com/openshift/cloud-credential-operator/pull/454

Comment 5 errata-xmlrpc 2022-03-16 11:30:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.8.34 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:0795


Note You need to log in before you can comment on or make changes to this bug.