Bug 20583 - ATAPI (ide) CD-RW drive continually reports "Error: not ready" once per second. Other normal CDROM drive is OK.
ATAPI (ide) CD-RW drive continually reports "Error: not ready" once per secon...
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: magicdev (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Mason
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-09 09:53 EST by Kent C. Brodie
Modified: 2007-04-18 12:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-21 15:12:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kent C. Brodie 2000-11-09 09:53:45 EST
After booting and logging into RedHat 7.0, the following message appears in the /var/log/messages
file.    The message appears approximately once to twice per second, and never stops:

kernel:    ATAPI device hdc:
              Error: Not ready (Sense key=0x02)
              (reserved error code) -- (asc=0x3a, ascq=0x01)
              The failed "Read Cd/Dvd Capacity" packet command was:
              "25 00 00 00 00 00 00 00 00 00 00 00"

This error seems specific to the CD-RW drive, and appears as soon as the login process is
complete.    There is not a disc in the CD-RW drive.    The PC has two IDE/ATAPI cd drives- one,
a standard CDROM (no problems), the other, a CD-RW drive, which reports the errors above.

The drive in question is a PLEXTOR 12/10/32A CD-rewriter.

This error seems related to the "Autorun" feature of Linux; disabling Autorun.kdelnk from the
"autostart" folder allows the error to stop-  but of course, the downside to that is that now BOTH
cd-drives will not function automatically when cd's are inserted.   (That simply cures the errors
from happening, but of course does not address the problem, an apparent flaw in the ide cdrom driver(s).)

This was not a problem or issue in RedHat 6.2, using the exact same hardware configuration.

The "severity=high" on this bug request is due to the massive number of error messages that
acculate in the system log file-- essentially rendering effective use of /var/log/messages useless
due to the amount of messages--  due to the constant activity on the hard drive (logging messages),
as well as the high potential for the /var file system to fill up rapidly.
Comment 1 niv_twig 2000-11-10 05:52:29 EST
This same problem happens to me. I hava a Yamaha CDRW8424 cd burner.
Comment 2 Need Real Name 2000-11-15 22:42:13 EST
I have the same thing with a pioneer 115 dvd. I am at redhat 6.2, kernal 2.2.16
Comment 3 Alan Cox 2000-11-28 12:25:58 EST
rpm -e magicdev --nodeps

Not a kernel bug but magicdev bugs
Comment 4 Kent C. Brodie 2000-11-29 02:00:15 EST
OK-- call me confused, but removing magicdev had NO EFFECT on the problem.

* I have removed magicdev (via the rpm command mentioned above)
* I replaced the "autorun.kdelnk" item in my "Autostart" folder, to re-enact
original settings.
* I have VERIFIED magicdev is not installed
* After the above steps-- the multiple messages/errors in the messages file
continue
  to appear- one per second at least.    Error being reported is exactly as I
described in my
  original bug submission.

Help?
Comment 5 Owen Taylor 2001-02-07 18:06:25 EST
If you are running KDE, then indeed the problem package
is autorun not magicdev. (Though magicdev may sometimes
produce similar messages.)

As for blaming it on "magicdev bugs", I'd like still like know what 
they are... everything it is doing is perfectly legal as 
far as I know,and if doing it causes the IDE device to start
generating errors, well, the kernel should be protecting
against that, not spewing messages.
Comment 6 Kent C. Brodie 2001-02-07 18:25:08 EST
As the external customer- I agree with the analysis just added...  that it's 
not magicdev-- that it's likely AUTORUN...     as a followup, are there any 
method(s) to "tweak" autorun to have it not cause the kernel to generate error 
messages once a second?  (Or do I just be patient and wait until autorun is 
patched?).     The common denominator in all this is the CD-RW drives-- and as 
reported, many flavors- not just one.   (and yes, I've updated my CD-RW's drive 
firmware to the latest).   Many thanks- I look forward to this.
Comment 7 Karsten Hopp 2001-02-12 19:35:28 EST
reassigned to package owner
Comment 8 Harald Hoyer 2001-02-20 11:26:05 EST
this is not the fault of autorun. It has to check if a media is present, so the
kernel has to provide an interface. If this interface is so verbose, the kernel
has to be blamed :)
Comment 9 Michael K. Johnson 2001-02-21 12:43:36 EST
It would be nice if magicdev and autorun could be configured to ignore
particular devices for wierd hardware that errors out when a perfectly
good command is sent to it.
Comment 10 Preston Brown 2001-02-21 12:58:23 EST
Michael, you commented out this debugging message from the kernel, correct?
Comment 11 Michael K. Johnson 2001-02-21 13:23:42 EST
No, I did *not* comment out that message.  It is a generic message
about problems with IDE devices, and disabling it would mean that
important messages would not get through.  I am not going to endanger
the data of people with working hardware in order to shut the kernel
up about broken hardware.

If folks do not like the messages about broken hardware, magicdev
and autorun MUST have configuration options available not to look
at certain devices.

(You may be thinking about the VFS disk changed message, which is
commented out, but that is not what this bug report is about.)
Comment 12 Kent C. Brodie 2001-02-21 15:12:25 EST
Is this really "broken hardware"?   I could understand that if this only 
happened with one specific CD-RW drive--  but as noted, several flavors of Cd-
RW drives are causing the kernel messages to appear.   I am assuming that 
autorun is querying the drive about the status ("got a cd yet?   got a cd 
yet?") and for whatever reason, doesn't like the answer.  

Therefore...   before blaming the hardware folks- is there something in 
the "answer" (status code) that is being returned that autorun/magicdev should 
allow, that it is currently complaining about?
Comment 13 David Mason 2001-02-22 10:16:53 EST
After further discussion all that was wanted for this by the kernel team was a
configuration option to turn off magicdev - that is there and has been there
since its inception - it can be found in the control center. I believe autorun
has the same thing.
Comment 14 Michael K. Johnson 2001-02-22 10:55:29 EST
Well, to resolve the original poster's complaint, magicdev and
autorun should have configuration options per device, not just
the choice to not run them at all.

If there is a configuration option for making magicdev only
look at one device, I'm not aware of it.

Note You need to log in before you can comment on or make changes to this bug.