Bug 205831 - device-mapper mirror: Bad status line output
Summary: device-mapper mirror: Bad status line output
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Alasdair Kergon
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-08 20:15 UTC by Jonathan Earl Brassow
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-30 16:44:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix status output of device-mapper mirror target (679 bytes, text/plain)
2006-09-08 20:15 UTC, Jonathan Earl Brassow
no flags Details

Description Jonathan Earl Brassow 2006-09-08 20:15:38 UTC
The device-mapper mirror target is putting out a status string that has trailing
white-space.  This is causing target tables to be loaded multiple times for the
same device during LVM operations like lvconvert and lvrename, because LVM is
doing a simple string comparison.  Loading multiple identical tables causes
serious problems with cluster mirroring especially.

This issue is not severe, as the work-around in user-space is trivial.  However,
it should be fixed in the kernel.  The attached patch is being push upstream.

Comment 1 Jonathan Earl Brassow 2006-09-08 20:15:38 UTC
Created attachment 135873 [details]
Patch to fix status output of device-mapper mirror target

Comment 2 Jonathan Earl Brassow 2006-11-13 23:04:37 UTC
There is a work-around in userspace for this in RHEL4.

This has been fixed in RHEL5/upstream.


Comment 3 Jonathan Earl Brassow 2006-11-30 16:44:13 UTC
Workaround in RHEL4.4
Fix in RHEL 5.0 (and also present upstream)



Note You need to log in before you can comment on or make changes to this bug.