Bug 205832 - kernel BUG at include/linux/list.h:185!
kernel BUG at include/linux/list.h:185!
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-08 16:18 EDT by pinkyred
Modified: 2015-01-04 17:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-11 20:22:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Console output during the backup (leading to kernel panix) (4.81 KB, text/plain)
2006-09-08 16:18 EDT, pinkyred
no flags Details

  None (edit)
Description pinkyred 2006-09-08 16:18:14 EDT
Description of problem:

I am running Fc5 2.6.17-2174 on a Tyan 2665 mobo with 4GB memory, dual xeon.  
I run several virtual machines (win2k3 server) as guests on this vmware server 
1.0 host.  Everything works great until:

When I launch backup exec to do a disk to disk backup (from sata raid on a 
2420SA, to an IDE drive hdb), the linux host goes into a kernel panic.  
Details of the console output are in the attached.  The first few lines show:

List corruption. next->prev should be f7481858, but was f748313c
------------[ cut here ]------------
kernel BUG at include/linux/list.h:185!
invalid opcode: 0000 [#1]
SMP 
last sysfs file: /class/scsi_host/host0/proc_name
Modules linked in: radeon(U) drm(U) ipv6(U) autofs4(U) ppdev(U) lm85(U) w83781d
(U) hwmon_vid(U) hwmon(U) i2c_isa(U) vmnet(U) vmmon(U) sunrpc(U) vfat(U) fat
(U) dm_mirror(U) dm_mod(U) video(U) button(U) battery(U) ac(U) lp(U) parport_pc
(U) parport(U) snd_intel8x0(U) snd_ac97_codec(U) snd_ac97_bus(U) ftdi_sio(U) 
snd_seq_dummy(U) usbserial(U) snd_seq_oss(U) snd_seq_midi_event(U) snd_seq(U) 
snd_seq_device(U) snd_pcm_oss(U) snd_mixer_oss(U) 3c59x(U) snd_pcm(U) e1000(U) 
mii(U) ohci1394(U) ieee1394(U) snd_timer(U) sg(U) snd(U) uhci_hcd(U) ehci_hcd
(U) i2c_i801(U) serio_raw(U) soundcore(U) e7xxx_edac(U) snd_page_alloc(U) 
floppy(U) i2c_core(U) edac_mc(U) ext3(U) jbd(U) aacraid(U) sd_mod(U) scsi_mod
(U)
CPU:    1
EIP:    0060:[<f88704ce>]    Tainted: P      VLI
EFLAGS: 00013096   (2.6.17-vmhost #1) 
EIP is at aac_intr_normal+0x1cc/0x267 [aacraid]
eax: 00000044   ebx: f7481858   ecx: c06b33b0   edx: 00003092
esi: f748180c   edi: f751c800   ebp: 000000e5   esp: c0787f88
ds: 007b   es: 007b   ss: 0068
Process vmware-vmx (pid: 2999, threadinfo=c0787000 task=e39f8c30)
Stack: f8872c57 f7481858 f748313c 00000000 f7447b5c e33cfda8 c04262dd 00000fa9 
       000000e5 f7447b5c 00000000 000000b1 f887171f c2abbe20 00000000 c0440a52 
       e3477d2c 00005880 c071b680 000000b1 c071b69c c0440b0a e495cfbc e3477d2c 
Call Trace:
 <c04262dd> do_timer+0x39/0x2e6  <f887171f> aac_rkt_intr+0x30/0x100 [aacraid]
 <c0440a52> handle_IRQ_event+0x23/0x4c  <c0440b0a> __do_IRQ+0x8f/0xe5
 <c0405f39> do_IRQ+0x67/0x84 
 =======================


Version-Release number of selected component (if applicable):
Kernel 2.6.17-2174 SMP

How reproducible:
As described above.

Steps to Reproduce:
1.  Heavy disk traffic (like launching a disk to disk backup) as described 
above.
  
Actual results:
Kernel panic, with list.h line 185.

Expected results:


Additional info:
I ran memory tests and everything is ok for the whole 4gb.
Comment 1 pinkyred 2006-09-08 16:18:14 EDT
Created attachment 135874 [details]
Console output during the backup (leading to kernel panix)
Comment 2 Dave Jones 2006-09-11 20:22:48 EDT
We can't debug problems where proprietary modules have been loaded.

Note You need to log in before you can comment on or make changes to this bug.