Bug 205869 - wp_tray crashes after adding directory
wp_tray crashes after adding directory
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: wp_tray (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-09 03:35 EDT by Dave Russell
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-11 07:35:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug-buddy crash report (12.27 KB, text/plain)
2006-09-09 03:35 EDT, Dave Russell
no flags Details
Fixes empty dir bug (931 bytes, text/x-patch)
2006-09-09 08:06 EDT, Denis Leroy
no flags Details
another bug-buddy dump (13.88 KB, text/plain)
2006-09-09 12:03 EDT, Dave Russell
no flags Details
Fix crashes with tiny images (794 bytes, text/x-patch)
2006-09-09 20:02 EDT, Denis Leroy
no flags Details
updated bug-buddy dump (13.88 KB, text/plain)
2006-09-10 07:06 EDT, Dave Russell
no flags Details
Global wp_tray patch, includes 2 previous ones (3.80 KB, patch)
2006-09-10 10:39 EDT, Denis Leroy
no flags Details | Diff

  None (edit)
Description Dave Russell 2006-09-09 03:35:58 EDT
Description of problem:
After adding a new directory to the wp_tray applet the applet crashed.

After installing bug-buddy I managed to genereate the attached bug report.

The directory I added did not have any images in, but the subdirectorys did.

Version-Release number of selected component (if applicable):
0.5.1
Please note that I am running this on a fully updated version of fc6-t2

How reproducible:
I am no longer able to start the applet without it crashing immediately.

Steps to Reproduce:
1. Install wp_tray
2. add a directory such as "/media/share/Images/Digital Blasphemy/"
3. watch it crash
  
Actual results:
wp_tray crashes

Expected results:
wp_tray should continue to run, preferably recursing into the subdirectories to
find the images.
Comment 1 Dave Russell 2006-09-09 03:35:58 EDT
Created attachment 135897 [details]
bug-buddy crash report
Comment 2 Dave Russell 2006-09-09 03:45:50 EDT
I created a new user on the machine and was able to re-create the crash with
another directory that had images in it. The same thing happened.
Comment 3 Denis Leroy 2006-09-09 08:06:26 EDT
Created attachment 135904 [details]
Fixes empty dir bug
Comment 4 Denis Leroy 2006-09-09 08:14:19 EDT
Can you try the attached patch ? I found a bug related to non-existing dir entries.

Also, check the file ~/.gconf/apps/wp_tray/%gconf.xml, make sure to remove it
and restart gconfd before you try to reproduce...

thx!

Comment 5 Dave Russell 2006-09-09 12:00:40 EDT
Downloaded srpm, patched, rebuilt and installed (after removing old one first
and tidying up after it).

Same problems, have attached a new bug-buddy bug report incase it throws up
anything else.
Comment 6 Dave Russell 2006-09-09 12:03:25 EDT
Created attachment 135907 [details]
another bug-buddy dump
Comment 7 Denis Leroy 2006-09-09 20:00:56 EDT
here's another patch that fixes crashes with tiny images, but I have a feeling
it's probably not the one you're hitting. BTW, you do have wp_tray-debuginfo
installed right ?

Now, wp_tray seems riddled with bugs. Just run in from a terminal and looking at
all those scary critical gdk/gtk warnings. I'll try to get rid of the most
obvious ones...
Comment 8 Denis Leroy 2006-09-09 20:02:34 EDT
Created attachment 135913 [details]
Fix crashes with tiny images
Comment 9 Dave Russell 2006-09-10 04:53:48 EDT
Thanks for the response Denis, it's a shame because in theory wp_tray is a
really cool little applet!

I didn't have the debuginfo package installed, but I do now, how do you run it
from the commandline?

Is the bug-buddy output of any use at all?

... and I think you're right, I'm almost certainly not hitting the tiny image bug.
Comment 10 Denis Leroy 2006-09-10 05:28:25 EDT
The bug-buddy output will be a lot more complete now that you have the debuginfo
package installed, even if you launch the applet from the GUI (can you repost
the bug-buddy info ?). Also, I don't think I can reproduce your particular crash
scenario. What steps do you perform to reproduce exactly ? (do you select any
options before adding a directory ?).
Comment 11 Dave Russell 2006-09-10 06:58:03 EDT
Exact steps are:
- add wp_tray to the upper panel
- right click on applet > preferences
- click on add
- select a directory with images in (it's an nfs share but that shouldn't matter)
- click apply
- right click Forward
- watch the applet explode :o(
- if I click reload then the applet crashes immediately

I can perform the following commands:
rm -rf ~/.gconf/apps/wp_tray/
gconftool-2 --shutdown

Then re-adding the applet works.

Note that if I add /usr/share/backgrounds/images then the forward works as
expected, but the "search" crashes... one bug at a time though ;o)


Comment 12 Dave Russell 2006-09-10 07:01:57 EDT
OK, I think I've narrowed it down...
If you directly add a directory with spaces in, then it seems to crash.
If you add a directory with subdirectories that have spaces in it, it's fine.

i.e.
for the following layout:

/images
       /dir1
       /dir 2

Adding "/images" works as expected (and it can recurse into dir 2
Adding "/images/dir 2" seems to blow chunks in a spectacular way.

Hope this helps.
Comment 13 Dave Russell 2006-09-10 07:06:30 EDT
Created attachment 135919 [details]
updated bug-buddy dump
Comment 14 Denis Leroy 2006-09-10 10:39:54 EDT
Created attachment 135928 [details]
Global wp_tray patch, includes 2 previous ones

Fixes:
 - doesn't display on vertical bar
 - crashes on paths with spaces
 - crashes with tiny images
 - warnings on gconf dir entries
 - crashes if pics directory doesn't exists
Comment 15 Denis Leroy 2006-09-10 10:48:46 EDT
The space-in-path problem turned out to be a boost library issue: it needs to be
told to behave 21st-century style on path names (damn Windows developers). :-)

I also reduce the size of the applet icon (which is a thumbnail of the current
background), do you like that change ?

The search/regular expression bug is still there, i'll fix that next.
Comment 16 Dave Russell 2006-09-10 11:14:25 EDT
I noticed the thumbnail... to be honest I prefer the old style!

Your fixes work for me :o)

While you're looking at "enhancements"... can you take a look at the colour that
surrounds images if the image is not as large as the screen resolution?

It's currently white, but it should probably follow the desktop preferences, or
be able to set it via the applet's preferences.

Thanks very much for the fixes so far!
Comment 17 Dave Russell 2006-09-10 11:15:08 EDT
I'll raise another bug if you'd prefer ;o) Just let me know.
Comment 18 Denis Leroy 2006-09-11 07:35:45 EDT
Summary of fixes:

- Fixed vertical toolbar thumbs
- Fixed crash with small image
- Fixed gconf directory warnings
- Fixed occasional false eror on exit
- Fixed crash with paths containing spaces
- Fixed crash with non-existant directory
- Search for substring rather than absolute name
- Empty search defaults as select all
- Fixed crash with incorrect search regex
- Added dialog for no search results case

> I noticed the thumbnail... to be honest I prefer the old style!

No problem I reverted to the old style, but for horizontal toolbars only. For
vertical toolbars, it shouldn't try to "bulge" out of the panel width.

> While you're looking at "enhancements"... can you take a look at the colour
> that surrounds images if the image is not as large as the screen resolution?

I'm sorry but i'm going to decline that one as I'm not willing to spend *that*
much time on wp_tray :-) I would suggest to bring this to the upstream project
directly.

Rebuilt for FC-4, FC-5 and FC-6.
Comment 19 Dave Russell 2006-09-11 07:56:12 EDT
Many thanks for all the mods, agreed on the thumbnail, you're right it shouldn't
malform the panel in a vertical alignment.

Will raise my RFE upstream.

Thanks again!

Note You need to log in before you can comment on or make changes to this bug.