Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 2058730

Summary: "nut" UPS monitor fails after update to libusbx-1.0.25-2.el9.x86_64
Product: Red Hat Enterprise Linux 9 Reporter: Gordon Messmer <gordon.messmer>
Component: libusbxAssignee: Nobody <nobody>
Status: CLOSED ERRATA QA Contact: Fendy Tjahjadi <ftjahjad>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: CentOS StreamCC: bstinson, ftjahjad, jwboyer, rvr, traterjr, ufven+fedora
Target Milestone: rcKeywords: Triaged
Target Release: ---Flags: pm-rhel: mirror+
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: libusbx-1.0.26-1.el9 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-11-15 11:15:16 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
strace output snippet following open of the usb device /dev/bus/usb/006/002
none
(successful start) strace output snippet following open of the usb device /dev/bus/usb/006/002 none

Description Gordon Messmer 2022-02-25 17:48:18 UTC
Created attachment 1863362 [details]
strace output snippet following open of the usb device /dev/bus/usb/006/002

Description of problem:
usbhid-ups from the "nut" UPS monitor works as expected with libusbx-1.0.24-4.el9.  However, after updating to libusbx-1.0.25-2.el9.x86_64, it is unable to identify a USB attached UPS.

I'll attach two snippets of strace output, one that fails (with 1.0.25 installed) and one that works as expected (with 1.0.24 installed).  If those are not useful, please let me know what other information might be.

/etc/ups/ups.conf contains:

[apc]
        driver = usbhid-ups
        port = auto


Version-Release number of selected component (if applicable):
libusbx-1.0.25-2.el9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Configure nut to monitor Back-UPS RS 1500MS, as above
2. Run "usbhid-ups -a apc"
3. Update to libusbx-1.0.25-2.el9.x86_64
4. Run "usbhid-ups -a apc"

Actual results:
usbhid-ups will report that it can't identify the UPS (info like "Manufacturer: unknown" and "Unable to get HID descriptor (No such device or address)") and exits.

Expected results:


Additional info:

Comment 1 Gordon Messmer 2022-02-25 17:49:10 UTC
Created attachment 1863363 [details]
(successful start) strace output snippet following open of the usb device /dev/bus/usb/006/002

Comment 2 Benjamin Berg 2022-02-25 18:03:44 UTC
Yeah, the CentOS version is messed up currently. I was working on solutions for Fedora, but haven't pushing anything new into CentOS had not been on my radar.

For now, I suggest downgrading to 1.0.24.

Comment 9 Benjamin Berg 2022-03-31 09:00:01 UTC
*** Bug 2065770 has been marked as a duplicate of this bug. ***

Comment 10 Benjamin Berg 2022-04-01 12:38:25 UTC
*** Bug 2070950 has been marked as a duplicate of this bug. ***

Comment 26 errata-xmlrpc 2022-11-15 11:15:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (libusbx bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:8292