Bug 205874 - Bad recovery from an initial X server startup failure during install.
Bad recovery from an initial X server startup failure during install.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rhpxl (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-09-09 05:32 EDT by Jeffery M. Chan
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: fc6t3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-19 14:31:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
FC5 /tmp after the two X server startup failures. (760.25 KB, application/octet-stream)
2006-09-09 05:32 EDT, Jeffery M. Chan
no flags Details
FC6t2 /tmp after hang (839.35 KB, application/octet-stream)
2006-09-09 05:34 EDT, Jeffery M. Chan
no flags Details
Patched FC5 version. Based on rhpxl-0.18 version used in FC5. (13.74 KB, text/plain)
2006-09-21 01:49 EDT, Jeffery M. Chan
no flags Details
rhpxl_patch.img.gz: Floppy image with patched xserver.py. For FC5 "linux updates". (6.99 KB, application/octet-stream)
2006-09-21 01:51 EDT, Jeffery M. Chan
no flags Details
rhpxl_patch.iso.gz: ISO with patched xserver.py. For FC5 "linux updates". (6.28 KB, application/octet-stream)
2006-09-21 01:52 EDT, Jeffery M. Chan
no flags Details

  None (edit)
Description Jeffery M. Chan 2006-09-09 05:32:07 EDT
Description of problem:

This is about the error recovery after an initial X server failure.

When I try to install FC5 on my machine.  I get the following error messages
on the console.

        Running anaconda, the Fedora Core installer - please wait...
        Probing for video card:   Nvidia / SGS Thomson (Joint Venture) Riva128
        Probing for monitor type:   Unknown monitor
        Attempting to start native X server
        Waiting for X server to start...log located in /tmp/X.log
        1...2...3...4...5....X SERVER FAILEDAttempting to start VESA driver X server
        Waiting for X server to start...log located in /tmp/X.log
        1...2...3...4...5....X SERVER FAILED X startup failed, falling back to
text mode

After this, I get the text mode version of the "Welcome to Fedora Core" message.

With FC6t2, the error message is different.

        Running anaconda, the Fedora Core system installer - please wait...
        Probing for video card:  Nvidia / SGS Thomson (Joint Venture) Riva128
        Attempting to start native X server
        Waiting for X server to start...log located in /tmp/ramfs/X.log
        1...2...3...4...5... X server started successfully.
        _X11TransSocketINETConnect() can't get address for localhost:6001:
Temporary failure in name resolution

        (mini-wm:504): Gtk-WARNING **: cannot open display: :1

And the system hangs at this point.

In both cases, I'm unable to run the graphical installer.

Why the X server failed initially?  This will be logged in a separate
bug report.  In a nutshell, the /tmp/XConfig.test uses a
depth that doesn't work with the RIVA128 card.

I hit alt-F2 and got to a root console.  From this I was able to tar
the /tmp directory and copy it to a floppy.  I've attached the following
tar files: fc5_tmp.tar.gz and fc6t2_tmp.tar.gz.


With FC4, I was able to successfully run the graphical installer.  I suspect
the native X server failed initially, but the VESA driver X server startup
was successful.

With the FC5 install, it looks like you try the native X server (nv driver),
and then try to start the VESA driver X server.  But all the X.log files
from the fc5_tmp.tar.gz shows that you try to startup the X server using
the nv driver.

With the FC6t2 install, there's an obvious error message but it looks like
the anaconda script believes that the server has started up successfully.
From the alt-F2 root console, doing an ps shows that both xorg and mini-wm
are defunct.

In both cases, some work is needed in the error recovery from a X server
failure.

-Jeff Chan


Version-Release number of selected component (if applicable):
        anaconda-11.1.0.77-1.i386

How reproducible:
        Install FC5/FC6t2 with a RIVA128 video card.
        I suspect you might also be able to reproduce this by altering
        anaconda to start X with an illegal depth using --bpp.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
        Be able to do a grapical install.

Additional info:
Comment 1 Jeffery M. Chan 2006-09-09 05:32:07 EDT
Created attachment 135899 [details]
FC5 /tmp after the two X server startup failures.
Comment 2 Jeffery M. Chan 2006-09-09 05:34:43 EDT
Created attachment 135900 [details]
FC6t2 /tmp after hang
Comment 3 Chris Lumens 2006-09-11 17:48:04 EDT
This should be better in test 3.
Comment 4 Jeffery M. Chan 2006-09-21 01:49:36 EDT
Created attachment 136817 [details]
Patched FC5 version.  Based on rhpxl-0.18 version used in FC5.
Comment 5 Jeffery M. Chan 2006-09-21 01:51:44 EDT
Created attachment 136818 [details]
rhpxl_patch.img.gz: Floppy image with patched xserver.py.  For FC5 "linux updates".
Comment 6 Jeffery M. Chan 2006-09-21 01:52:35 EDT
Created attachment 136819 [details]
rhpxl_patch.iso.gz: ISO with patched xserver.py.  For FC5 "linux updates".
Comment 7 Jeffery M. Chan 2006-09-21 02:12:26 EDT
I'll confirm that FC6t3 works.  Thanks.


I've looked through the rhpxl code and have come up with a patched
version of xserver.py.  Only two lines are affected.

This should allow people to get the GUI install on FC5 with the RIVA128 card.

Use the floppy image if you have the floppy drive: download, un-gzip and
dd to create floppy (see http://rhlinux.redhat.com/anaconda/updatedisks.html).

If you have a second CD drive, you can burn the ISO file.

To use, enter "linux updates" on the boot prompt.  FC5 will eventually
ask which drive the patch is located (fd0, hdb, hdc, hdd, etc.).

You should be able to get the GUI after this.

At this point, though, I suppose only the impatient can use this.

-Jeff Chan

Note You need to log in before you can comment on or make changes to this bug.