Bug 205883 - When printing, deskop printing icon doen's appear on notificaiton area
When printing, deskop printing icon doen's appear on notificaiton area
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: desktop-printing (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-09-09 10:41 EDT by sangu
Modified: 2013-03-13 00:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-11 13:16:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2006-09-09 10:41:13 EDT
Description of problem:
When printing, deskop printing icon doen's appear on notificaiton area.
$ lpq
tp0 is ready
Rank    Owner   Job     File(s)                         Total Size
1st     sangu   18      evince-print                    1754112 bytes
2nd     sangu   19      evince-print                    63488 bytes

Version-Release number of selected component (if applicable):
0.19-12

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
hal-cups-utils-0.6.2-3
hal-0.5.7.1-3.fc6
dbus-0.92-1.fc6
cups-1.2.3-3
Comment 1 Matthias Clasen 2006-09-10 11:53:47 EDT
is eggcups running when this happens ?
Comment 2 Matthias Clasen 2006-09-10 23:38:08 EDT
Tim, did the dbus patch not survive the cups 1.2 update ?
Comment 3 Tim Waugh 2006-09-11 05:57:37 EDT
It was merged in for 1.2.  We no longer apply our own dbus patch, but upstream
CUPS 1.2 should be doing everything our old patch did, even with the same signal
names.

Looking more closely though it looks like JobQueuedRemote might not be there
now.  Could that be causing the problem?
Comment 4 Matthias Clasen 2006-09-11 10:28:42 EDT
From what Tim and I figure out on irc, it appears that upstream cups uses
the com.redhat.PrinterSpooler dbus interface that we had in our original patch,
while eggcups in rawhide got converted to use org.freedesktop.PrinterSpooler 
in Feb 05. 
Comment 5 Matthias Clasen 2006-09-11 12:31:41 EDT
Florian will fix this to use com.redhat.PrinterSpooler everywhere.

Note You need to log in before you can comment on or make changes to this bug.