Bug 205889 - Creating xen install with xenguest-install fails
Creating xen install with xenguest-install fails
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-09 12:11 EDT by Jurgen Kramer
Modified: 2013-01-09 23:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-11 14:25:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jurgen Kramer 2006-09-09 12:11:43 EDT
Description of problem:
When trying to create a xen installation the xenguest-install script fails after
the first question

Version-Release number of selected component (if applicable):
xen-libs-3.0.2-33
xen-3.0.2-33


How reproducible:
always

Steps to Reproduce:
1. Start xenguest-install
2. Select yes (or no) on first question
3.
  
Actual results:
[root@macbook ~]# xenguest-install 
Would you like a fully virtualized guest (yes or no)?  This will allow you to
run unmodified operating systems. yes

Traceback (most recent call last):
  File "/usr/sbin/xenguest-install", line 375, in ?
    main()
  File "/usr/sbin/xenguest-install", line 306, in main
    guest = xeninst.FullVirtGuest()
  File "/usr/lib/python2.4/site-packages/xeninst/FullVirtGuest.py", line 29, in
__init__
    XenGuest.XenGuest.__init__(self)
  File "/usr/lib/python2.4/site-packages/xeninst/XenGuest.py", line 100, in __init__
    self.conn = libvirt.open(None)
  File "/usr/lib/python2.4/site-packages/libvirt.py", line 39, in open
    if ret is None:raise libvirtError('virConnectOpen() failed')
libvirt.libvirtError: virConnectOpen() failed



Expected results:


Additional info:
Starting with xenguest-install -v gives the same result
Comment 1 Jesse Keating 2006-09-10 12:15:58 EDT
What does /var/log/xen* show?
Comment 2 Jurgen Kramer 2006-09-11 13:58:46 EDT
There is only a var/log/xen/xend.log that file is empty:

[root@macbook log]# ll /var/log/xen/*
-rw-r--r-- 1 root root 0 Sep  9 18:21 /var/log/xen/xend.log

Can this tool only be used when running the xen kernel? I'm not running the xen
kernel currently because of bug #205892

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=205892
Comment 3 Jesse Keating 2006-09-11 14:25:10 EDT
Yes, you need to be running the Xen kernel as xenguest-install is creating xen
guests, which needs the kernel.  I'm closing this as notabug..
Comment 4 Jurgen Kramer 2006-09-12 12:16:27 EDT
OK, but a helpful error message would be nice instead of the horrible errors
messages. Maybe there is a simple check to see if you're running on a xen
enabled kernel?

Note You need to log in before you can comment on or make changes to this bug.