Bug 205897 - [Areca RHEL 5.1] Add kernel support for Areca RAID controllers (include arcmsr driver from 2.6.19)
[Areca RHEL 5.1] Add kernel support for Areca RAID controllers (include arcms...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Henzl
Brian Brock
: OtherQA
: 176802 235515 247129 (view as bug list)
Depends On:
Blocks: 222082 233399 238014 262181
  Show dependency treegraph
 
Reported: 2006-09-09 14:52 EDT by Dax Kelson
Modified: 2010-10-22 01:59 EDT (History)
21 users (show)

See Also:
Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 14:13:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The patch for RHEL 5.1 (108.19 KB, patch)
2007-04-26 06:10 EDT, Nick Cheng
no flags Details | Diff

  None (edit)
Description Dax Kelson 2006-09-09 14:52:00 EDT
Description of problem:
The arcmsr driver provides support for a line of extremely high performance RAID
cards. This includes PCI Express SATA controllers.

Their website is: http://www.areca.us/

The arcmsr driver has cleared all reviewer hurdles, and now James Bottomley has
it in his scsi-misc git tree for merge (waiting for 2.6.19 to open).

As of today, the driver is located at:

http://kernel.org/pub/linux/kernel/people/jejb/scsi-misc-2.6.diff

Please include this driver in the RHEL5 kernel.

BTW, Ubuntu has included this in their kernel since 6.06 LTS.
Comment 1 Tom Coughlan 2006-09-11 09:40:54 EDT
RHEL 5 will be based on the 2.6.18 kernel. Unfortunately, this will not include
the arcmsr driver, and it is too late in the RHEL 5 development schedule to add
a new driver like this. I will put this on the list for consideration on in 5.1.
I will also see about getting some hardware here so we can test and support it
properly. 
Comment 4 dijuremo 2006-09-28 10:11:25 EDT
These cards have been out there for a while already, it is actually irritating
that Red Hat does not provide support for them. They perform even better than
any other SATA raid card available in the market. Hacking the install kernel to
add the drivers is a pain. The least you guys could do is provide a driver disk
if you are not including the driver in the kernel.

I currently use these cards in 7 of my servers running RHEL4 and updating a
kernel is a pain since I also have to go through the extra step of manually
building and installing the driver.

There is even a driver disk for CentOS and several kernel rpms as well as an
srpm provided at http://www.bodgit-n-scarper.com/code.html#centos, so you guys
really need to step up and include this somehow or provide a download to make it
easy for the end users to include this cards.
Comment 5 dijuremo 2006-09-29 13:57:40 EDT
Hi Dax and all,

Here is a driver disk for RHEL5 Beta1 x86_64:

https://services.ibb.gatech.edu/wiki/index.php/Howto:Software:Areca#Driver_Disk_for_RHEL5-beta1

Enjoy,

Diego
Comment 6 dijuremo 2007-02-28 07:39:37 EST
The Areca drivers were oficially merged in the 2.6.19 Kernel tree. Should we
expect a backported patch to the RHEL5 release kernel (2.6.18)?  These cards are
really very popular and beat the 3ware 95XX series models. The new Areca cards
based on the IOP341 chipset are extremely fast. I have used the Areca cards with
RHEL4 for almost two years now and have not had any problems other than the pain
to install the OS since the drive is not part of the kernel in RHEL4.

Installing a new machine is sort of a pain and if the driver is now oficially in
the kernel, then backporting it should be the way to go. I plan to update to
RHEL5 when it comes out and would really like this driver to be included in the
kernel if possible.
Comment 8 Andrius Benokraitis 2007-03-01 01:21:33 EST
Adding Areca... Kevin, does Erich have a Bugzilla account?

Diego - Red Hat understands your frustration in this matter but we must rely
heavily on the vendor to provide equal support for any drivers we include in our
distro. We are in the process of acquiring more information from Areca at this
time. 

Although it is quite technically trivial to include a backported patch into
RHEL, there are a *lot* of other items that must go along with this, which
include things such as joint support alignment, joint roadmap alignment and
planning, and most importantly internal QA.

It's great to hear that the cards Just Work, but Red Hat must make sure all
bases are covered in case things don't go so smoothly for others. We are looking
forward to testing this for possible inclusion.

Stay Tuned! :-)
Comment 9 dijuremo 2007-03-05 12:45:14 EST
The drivers are now part of the kernel tree in 2.6.19, so I though that would be
enough assurance that their hardware is supported under linux. Unfortunately, I
do not have a support contract for my RHEL4 boxes since our campus has a site
license and we have our own Satelite server with no support, otherwise, I would
have inquired about Red Hat backporting the drivers earlier for RHEL4. It was
not until I got the first beta of RHEL5 when I noticed the drivers were not
there, but that was to be expected, as the driver was not officially accepted
and released as part of the Linux kernel until 2.6.19.

However, since the driver is now officially part of the kernel, I would like to
ask you guys to really consider including a back ported patch on the 2.6.18
RHEL5 kernels.  Even if it is not right away on RHEL5 release; at least add it
to the list of things to consider for a possible Update 1 or Update 2 releases
of RHEL5.

I know how to create Initrds and manually add the driver to boot from a USB
keychain from which I boot to then install RHEL over the network. After the
system is kickstarted, I run up2date in thye %post% section to fully patch the
system from the sattelite and then I make sure I have the RPMS for the driver
compiled for the latest kernel (which the system will get from up2date) and
install the RPMS after applying updates. However, every time a new kernel is
released, I need to re-compile the drivers, so if they were included in the
release kernel, it would be as easy as up2date -uf then reboot, which would be
so convenient.

Thanks for looking into this. I know I am not the only one using the Areca
cards. The people from the CentOS project actually now provide RPMS to install
the areca drivers with their distribution. I know CentOS is a re-compile of the
RHEL SRPMS, so I know it is very possible, but I also understand Red Hat has to
do testing and such, before supporting the hardware. The faster this process is
started, the faster the end user will get it. 

Thanks in advance for any progress you can make towards including the driver.

Diego
Comment 10 Andrius Benokraitis 2007-03-05 13:09:41 EST
Diego,

Building and providing the code is the trivial part. We are more interested in
making sure Areca's support channels are 100% committed to RHEL for escalations,
 and that Red Hat has sufficient resources in development/QA to support the cards.

We are in the midst of a dialog with Areca to ensure that they can support the
RHEL platforms for the *entire* life of the product (7+ years).

You are correct though, the code would have to be backported into a future minor
release to make it into base RHEL 4 or RHEL 5.

Specifically for your situation, since you are pretty much self-supported though
in your organization anyway, maybe you could convince Areca to at least
build/provide/support DUDs for RHEL4/RHEL5 and post them on their website to
make your life easier in the meantime? See http://www.kerneldrivers.org/
Comment 11 nickcheng 2007-03-05 22:31:30 EST
Dear all,

Thanks for your efforts to care Areca driver.
Areca has signed the NDA and sent off the adapters for RedHat's need.
Areca will continuously support this driver as before without a doubt.

Appreciate your help!!
Comment 13 dijuremo 2007-03-06 07:37:45 EST
> Specifically for your situation, since you are pretty much self-supported though
> in your organization anyway, maybe you could convince Areca to at least
> build/provide/support DUDs for RHEL4/RHEL5 and post them on their website to
> make your life easier in the meantime? See http://www.kerneldrivers.org/

Hi,

Like I said, I know how to do this, it is just a pain to have to do it every
time.  I actually even provide a driver disk for RHEL5 Beta1 on the web site:

https://services.ibb.gatech.edu/wiki/index.php/Howto:Software:Areca

However, the initial install is not the only pain, every kernel update means
extra work. So I am really looking forward to this being added to the release
kernels.

Thanks for all your help. I hope the driver can be added soon after passing all
your required tests.
Comment 14 Andrius Benokraitis 2007-03-23 03:04:34 EDT
*** Bug 176802 has been marked as a duplicate of this bug. ***
Comment 17 Tom Coughlan 2007-04-23 15:36:23 EDT
Nick,

Please post a patch to add the arcmsr driver to RHEL 5.1. You can use the 5.0
source tree for this. If there are any differences from the driver in the
upstream kernel please describe them and explain why they are not upstream. If
you have changes that have not yet been posted to linux-scsi please do so. Thanks.

Tom
Comment 18 dijuremo 2007-04-25 13:21:09 EDT
I have created a driver disk by taking the areca driver from the 2.6.19 kernel
tree and compiling it on a RHEL5 machine running the 2.6.18-8 release kernel. 
You may download and play with it at:

https://services.ibb.gatech.edu/wiki/index.php/Howto:Software:Areca#Driver_Disk_for_RHEL5

Diego.
Comment 19 Andrius Benokraitis 2007-04-25 14:04:09 EDT
Nick, you should have gotten my instructions on how to obtain the RHEL 5.0
source ISOs from RHN, no?
Comment 20 Nick Cheng 2007-04-25 21:38:30 EDT
(In reply to comment #19)
> Nick, you should have gotten my instructions on how to obtain the RHEL 5.0
> source ISOs from RHN, no?
Andrius,
I have downloaded the ISOs and made a driver disk for i686/X86_64.
But it is not final-tested by the FAE team.

Comment 21 Nick Cheng 2007-04-25 21:40:52 EDT
(In reply to comment #19)
> Nick, you should have gotten my instructions on how to obtain the RHEL 5.0
> source ISOs from RHN, no?
Andrius,
I have downloaded the ISOs and made a driver disk for i686/X86_64.
But it is not final-tested by the FAE team.

Comment 22 Dax Kelson 2007-04-25 21:52:07 EDT
Nick are you going to post a patch per comment #17?
Comment 23 Nick Cheng 2007-04-25 22:11:04 EDT
Dax,
Yes, I am doing the patch. 
Yesterday, I made sure of some tiny thing with Tom. I guess it could be posted
today. 
Comment 24 Andrius Benokraitis 2007-04-25 23:38:44 EDT
Nick - great to hear - please post the patch in the attachment section below of
this bugzilla when it is ready to go.
Comment 25 Nick Cheng 2007-04-26 06:10:32 EDT
Created attachment 153490 [details]
The patch for RHEL 5.1
Comment 26 Andrius Benokraitis 2007-04-26 11:30:25 EDT
*** Bug 235515 has been marked as a duplicate of this bug. ***
Comment 27 Tomas Henzl 2007-05-03 04:56:50 EDT
Hello Nick,
When I am testing the driver, probably when the software tries to
read(write) just after the size of the device I am getting this error message -
 
Error writing file at offset 479999295488 (447.03G): Input/output error
 
as opposed to

Error writing file at offset 480001392640 (447.04G): No space left on device
(EOF, ignored)

which would be OK.

I do not know if this is a subtle error in the driver or a feature or if I am
doing something wrong.
My test config. is: Areca 1220 with 3 sata disks in raid 0+1 attached.
I'll send the test software to you soon.

Tomas
Comment 28 nickcheng 2007-05-08 20:58:55 EDT
Hi all,
It seems Tomas not receiving my emails these two days.
Anyways, we have a question about the test program.

We though writing with 1Mbytes is not reasonable.
Even though I use a Maxtor SATA disk which is LBA 160086528 and connecting the
MB directly without any partition, I still could get the input/output error.
The SATA disk's full size is 160086528 x 512bytes=81964302336bytes.
If we  write it with 1Mbyte,  because 81964302336 is not the multiple of 1M(512
x 512), it will return error in the last writing.
If the input/output error happend in the raw SATA disk as well, it doesn,t make
sense, right?


Comment 29 Tomas Henzl 2007-05-11 08:15:57 EDT
Everything has been clarified and is working for me OK now,
so the patch is posted as
http://post-office.corp.redhat.com/archives/rhkernel-list/2007-May/msg00270.html
Comment 30 RHEL Product and Program Management 2007-05-11 08:21:59 EDT
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.
Comment 31 nickcheng 2007-05-13 20:22:49 EDT
Thanks for all of your efforts
Comment 32 dijuremo 2007-05-14 10:49:06 EDT
I do not believe the code needed to add the areca drivers to RHEL4 is much
different, are the any plans to also back port this patch to RHEL4's 2.6.9 kernel?

Diego
Comment 33 Andrius Benokraitis 2007-05-14 10:52:20 EDT
Diego - see bug 233399.
Comment 34 Tomas Henzl 2007-05-23 10:29:04 EDT
Nick,

please could you specify on which architectures Areca
has tested and will support this driver ? 

Should we exclude ia64?  Other RHEL archs? 

Tomas

Comment 35 nickcheng 2007-05-23 21:00:07 EDT
Tomas,
Areca driver could support x86_64, i386, Sparc, Sparc64 and PowerPC.
Comment 36 Don Zickus 2007-06-12 15:01:50 EDT
in 2.6.18-24.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 37 Brent 2007-06-12 15:42:24 EDT
I only see a path up to 23.el5 at the above location, not quite ready?
Comment 38 Andrius Benokraitis 2007-06-18 12:19:35 EDT
Brent - try the link now... you can try any kernel -23.el5 or newer.
Comment 39 Andrius Benokraitis 2007-06-18 12:20:26 EDT
Sorry... rather -24.el5 or newer...
Comment 40 nickcheng 2007-07-02 22:05:30 EDT
Hi guys,
I heard RH complains Areca delays the process.
Is it true?
If yes, please let me know where.
Comment 41 Andrius Benokraitis 2007-07-05 15:42:17 EDT
Nick - Can you be more specific? AFAIK, there are no items waiting on Areca,
except the need to test the driver included in the link in Comment #36 above.
Comment 42 nickcheng 2007-07-05 21:35:07 EDT
An important customer in Euro stated that a PM in RH argued Areca slowd the
certification process.
I thought the process came along quite well and I am bewildered by the compliant.   
Therefore I have to inquire the reason why it happened.
I will pass your message to our customer.
Thanks,
Comment 43 Andrius Benokraitis 2007-07-05 23:31:47 EDT
Nick, if you have the name of the Red Hatter you can pass on to me, that would
be great. I am also bewildered as well, since there is no official
"certification" per se on hardware devices or peripherals. This is the first
I've heard of any dissatisfaction on the current strides to include the Areca
driver after formalizing the relationship. Obviously there has been some
clamoring to have the driver included in RHEL, but it was only included into
Fedora recently.
Comment 44 Tomas Henzl 2007-07-06 04:23:28 EDT
Nick, I haven't heard about this, and as for me I'm not complaining.
Comment 45 nickcheng 2007-07-06 05:10:33 EDT
OK, thanks.
Comment 48 John Poelstra 2007-08-27 14:18:44 EDT
A fix for this issue should have been included in the packages contained in the
RHEL5.1-Snapshot3 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed as soon as possible to
ensure that it is included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

More assistance: If you cannot access bugzilla, please reply with a message to
Issue Tracker and I will change the status for you.  If you need assistance
accessing ftp://partners.redhat.com, please contact your Partner Manager.
Comment 49 Chip Coldwell 2007-08-28 13:40:48 EDT
*** Bug 247129 has been marked as a duplicate of this bug. ***
Comment 50 John Poelstra 2007-08-30 20:27:52 EDT
A fix for this issue should have been included in the packages contained in the
RHEL5.1-Snapshot4 on partners.redhat.com.  

Requested action: Please verify that your issue is fixed *as soon as possible*
to ensure that it is included in this update release.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to FAILS_QA.

If you cannot access bugzilla, please reply with a message to Issue Tracker and
I will change the status for you.  If you need assistance accessing
ftp://partners.redhat.com, please contact your Partner Manager.
Comment 52 errata-xmlrpc 2007-11-07 14:13:02 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html

Note You need to log in before you can comment on or make changes to this bug.