Bug 205901 - Can the root window color be changed to match new fedora background
Can the root window color be changed to match new fedora background
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-xinit (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks: FC6Desktop
  Show dependency treegraph
 
Reported: 2006-09-09 16:24 EDT by louisgtwo
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 23:19:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description louisgtwo 2006-09-09 16:24:57 EDT
With the new fedora background being almost black when logging on the root
window is blueish before nautilus can draw the background. Can the color of the
root window be changed to match?
Comment 1 Matthias Clasen 2006-09-11 12:19:39 EDT
We should wait for the final background before doing this, though.
Diana wants to lighten it up a bit.
Comment 2 Adam Jackson 2006-09-15 17:01:56 EDT
Moving this one to gdm, plain X doesn't have the ability to set any root window
color at startup besides black.
Comment 3 Matthias Clasen 2006-09-22 10:00:08 EDT
the problem seems to be that we are setting two different colors in two
different places:

/etc/gdm/PreSession/Default gets the color configured in the gdm config file
and sets it, then later

/etc/gdm/Xsession includes /etc/X11/xinit/xinitrc-common, which overrides that
with a hardcoded color of #222E45.

The fix would be to move the xsetroot call from xinitrc-common to xinitrc.
Comment 4 Matthias Clasen 2006-09-25 23:19:36 EDT
fixed in 1.0.2-11.fc6

Note You need to log in before you can comment on or make changes to this bug.