Bug 205923 - New version of iproute broke vpnc-script
New version of iproute broke vpnc-script
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vpnc (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-10 02:10 EDT by Cory Bell
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: vpnc-0.3.3-7.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-12 12:40:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to strip hoplimit from output of ip route get (335 bytes, patch)
2006-09-10 02:10 EDT, Cory Bell
no flags Details | Diff

  None (edit)
Description Cory Bell 2006-09-10 02:10:56 EDT
Description of problem:
The recent update to iproute-2.6.16-1.fc5 broke vpnc (more accurately, it broke
/etc/vpnc/vpnc-script). The new iproute adds a "hoplimit" value to the output of
"ip route get <ipsec_gw_address>". Because fix_ip_get_output doesn't know to
remove it (and it isn't a valid parameter to "ip route add"), the attempt to add
a route to the VPN concentrator fails with "Error: either "to" is duplicate, or
"hoplimit" is a garbage."

The fix is easy, just modify fix_ip_get_output to strip the hoplimit value.
Patch will be attached shortly.

Version-Release number of selected component (if applicable):
vpnc-0.3.3-7.2

How reproducible:
100% since updating to iproute-2.6.16-1.fc5.

Steps to Reproduce:
1. Update to iproute-2.6.16-1.fc5
2. Try to connect to a VPN concentrator
3. Enjoy not being able to pass any packets
  
Actual results:
Error adding route to VPN concentrator

Expected results:
Sucessful addition of route to VPN concentrator
Comment 1 Cory Bell 2006-09-10 02:10:56 EDT
Created attachment 135916 [details]
Patch to strip hoplimit from output of ip route get
Comment 2 Alessandro Suardi 2006-09-10 21:15:42 EDT
Bug reproduces for me on two different VPN concentrators.
Reverted for now to iproute-2.6.15-1.2.
Comment 3 Alessandro Suardi 2006-09-17 20:57:08 EDT
Just to confirm that vpnc-0.3.3-7.3 and newer iproute work fine together.
Comment 4 Lans Carstensen 2006-10-10 00:32:13 EDT
This is confirmation that vpnc-0.3.3-7.3 works properly on RHEL5 beta 1, whereas
-7.2 does not.

Note You need to log in before you can comment on or make changes to this bug.