Bug 205932 - hardcoded net-scripts dependency
hardcoded net-scripts dependency
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks: 195365
  Show dependency treegraph
 
Reported: 2006-09-10 10:29 EDT by Denis Ovsienko
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-29 15:42:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Denis Ovsienko 2006-09-10 10:29:50 EDT
Hello. The default Fedora dhclient-script tries to use file from initscripts
package unconditionally. If those files are not in place, we get the following
complaints (the address is still assigned though):

/sbin/dhclient-script: line 96:
/etc/sysconfig/network-scripts/network-functions: No such file or directory
/sbin/dhclient-script: line 104: need_config: command not found
/sbin/dhclient-script: configuration for devnet not found. Continuing with defaults.
/sbin/dhclient-script: line 112: source_config: command not found
/sbin/dhclient-script: line 96:
/etc/sysconfig/network-scripts/network-functions: No such file or directory
/sbin/dhclient-script: line 104: need_config: command not found
/sbin/dhclient-script: configuration for devnet not found. Continuing with defaults.
/sbin/dhclient-script: line 112: source_config: command not found
/sbin/dhclient-script: line 68: change_resolv_conf: command not found

One could ask, how could the system run without initscripts package. The answer
would be that the files don't belong to initscripts, but to net-scripts part of
it, which could be packaged separately. More details about this split could be
found in bug #195353.
Could we have a little more checks for file sourcing and function calls?
Thank you.

Version-Release number of selected component (if applicable):
dhclient-3.0.4-20.fc6
Comment 1 David Cantrell 2006-09-29 15:42:20 EDT
Well, 195353 is CLOSED WONTFIX, so I'm not going to modify the dhclient-script.
 This one is CLOSED WONTFIX.

I can understand wanting a different network configuration subsystem, but it
becomes really difficult to abstract those layers and at some point, you do need
some sort of glue between all of the parts the distribution provides and the
parts you want to replace.  If I was to conditionalize the sourcing of various
initscripts files, how would I handle the instances where I want to run one of
the functions provided by those files?  Is your netscripts replacement going to
provide functions by the same name?  If so, great, but what about other
replacements?

This is a reasonable project, but I think the approach is wrong.  Closing this
bug since 195353 is closed.

Note You need to log in before you can comment on or make changes to this bug.