Bug 205937 - Booting a paravirt xen install of rawhide stalls after mounting ext3
Booting a paravirt xen install of rawhide stalls after mounting ext3
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks: FC6Test3Blocker
  Show dependency treegraph
 
Reported: 2006-09-10 11:23 EDT by Jesse Keating
Modified: 2013-01-09 21:33 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-12 15:00:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2006-09-10 11:23:01 EDT
I installed rawhide from 20060909 into paravirt xen (x86_64 and i386). 
Installation goes mostly OK, however upon reboot the system gets no further than:

Registering block device major 202
 xvda: xvda1 xvda2
device-mapper: ioctl: 4.7.0-ioctl (2006-06-24) initialised: dm-devel@redhat.com
kjournald starting.  Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.

I can send a shutdown command w/ xm shutdown <domain> and the screen outputs:

Removing netfilter NETLINK layer.
md: stopping all md devices.
System halted.
Comment 1 Jeremy Katz 2006-09-11 10:12:18 EDT
Did you set up a graphics console?  If so, were you connected with vncviewer?
Comment 2 Jesse Keating 2006-09-11 10:21:36 EDT
Hrm, I was not... I just did xm create -c <confname>.  On my x86_64 system it
goes all the way to login prompt, and then shortly afterward crashed the host
due to smp codes....
Comment 3 Jeremy Katz 2006-09-11 10:46:16 EDT
xm create -c is only going to give you the "serial" console right now (the same
nonsensical behavior that you get with fully virt).  I've got a note to fix that
up, but not sure if that'll make FC6 at this point -- virt-manager gets things
right.

But I expect that this isn't hung and it's just that you're not getting the
console output because it's going to the fbcon.
Comment 4 Jeremy Katz 2006-09-11 13:35:59 EDT
.. and things work fine for me on a fresh install
Comment 5 Jesse Keating 2006-09-12 15:00:52 EDT
I can no longer reproduce.  NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.