Bug 205980 - /usr/lib/libgcrypt.la missing from libgcrypt-devel package
/usr/lib/libgcrypt.la missing from libgcrypt-devel package
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libgcrypt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-11 03:19 EDT by Mayank Jain
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-11 12:22:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mayank Jain 2006-09-11 03:19:06 EDT
Description of problem:
/usr/lib/libgcrypt.la missing from libgcrypt-devel package, while the same file
gets intalled when installing libgcrypt from source.

Version-Release number of selected component (if applicable):
Not present in
libgcrypt-1.2.3-1
libgcrypt-devel-1.2.3-1

Present, when compiled libgcrypt-1.2.3 from source.

How reproducible:
Always

Steps to Reproduce:
1. Install libgcrypt* using yum from rawhide
2. ls /usr/lib/libgcrypt.la shows file not found

  
Actual results:
ls /usr/lib/libgcrypt.la shows file not found

Expected results:
/usr/lib/libgcrypt.la should be installed.

Additional info:
I'm using rawhide.
Comment 1 Nalin Dahyabhai 2006-09-11 12:22:16 EDT
The .la file is intentionally not packaged, as directed in the Fedora packaging
guidelines (http://www.fedoraproject.org/wiki/Packaging/Guidelines, section
"Exclusion of Static Libraries").

I personally disagree with excluding static libraries and .la files, but for
consistency's sake I comply with it.

The guidelines also note that if there is an application in Fedora which
requires its presence, that'd be reason enough to include the .la file.  If
you've found such a case, please reopen this bug (in the meantime I'll close it
won't-fix).  Thanks!

Note You need to log in before you can comment on or make changes to this bug.