Bug 206009 - kdm: login hangs for 30 sec if network enabled but disconnected
kdm: login hangs for 30 sec if network enabled but disconnected
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kdebase (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-11 10:17 EDT by Daniel Ganek
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:41:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Ganek 2006-09-11 10:17:41 EDT
Description of problem:

If the network is enabled but the network is disconencted; e.g., the cable
unplugged, user login hangs for 30 seconds. it doesn't matter if
a) nfs or amd is enabled or not
b) using a static IP address or DHCP
c) which desktop the user uses: one of our users uses mwm.

Neither gdm nor unix login(i.e., run level 3) exhibit this problem.

Version-Release number of selected component (if applicable):

 kdebase-3.1.3-5.5

How reproducible:

Steps to Reproduce:
1. Use kdm for login
2. Enable the network
3. Unplug the network cable
4. Try to login

Actual results:
Login dialog remains for about 30 sec. System then
logs the user in normally. 


Expected results:
Login should proceed promptly; i.e. in a second or two.


Additional info:
Logout hangs too.
Comment 1 Daniel Ganek 2006-09-11 16:56:16 EDT
More info:

Using strace I determined the a child of kmd; i.e. "-:0" is querying
the DNS servers and it's takes awhile for these queries to time out.

Comment 2 Daniel Ganek 2006-09-11 16:57:04 EDT
KDE says 3.1.3 is too old to fiel a BZ.

Comment 3 Daniel Ganek 2006-09-18 14:13:32 EDT
More info

One of our name servers went down and kdm now hangs even if the network
is connected. So, it looks like kdm is requiring a response from ALL
name servers not just one. 

I removed the ip address of the missing name servers and login worked as it should.
Comment 4 RHEL Product and Program Management 2007-10-19 14:41:18 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.