Bug 206030 - multilib packages succeed verification for differing files
multilib packages succeed verification for differing files
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
5
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-11 12:14 EDT by Jan Kratochvil
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-12 03:34:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2006-09-11 12:14:41 EDT
Description of problem:
rpm-database has weird state for multilib packages.
It shows files not existing there while even succeeding their verification (-V).

Version-Release number of selected component (if applicable):
rpm-4.4.2-15.2

How reproducible:
Always.

Steps to Reproduce:
1. rpm -qlv dbus.x86_64 dbus.i386|grep '/bin/dbus-daemon$'
2. rpm -V   dbus.x86_64 dbus.i386|grep '/bin/dbus-daemon$'

Actual results:
1. -rwxr-xr-x    1 root    root           639104 May  5 19:40 /bin/dbus-daemon
   -rwxr-xr-x    1 root    root           687816 May  5 19:41 /bin/dbus-daemon
2. [nothing]

Expected results:
1. -rwxr-xr-x    1 root    root           687816 May  5 19:41 /bin/dbus-daemon
2. [nothing]

Or some other indication that the .i386 file instance does not exist there.

Additional info:
I have seen even -V failing the verification but I cannot reproduce it now.
The -V step was correct this way but the whole user perception is also wrong.

"dbus" is only a multilib package sample here.
Comment 1 Jeff Johnson 2006-09-11 18:58:56 EDT
Files have state associated, display a file's state by doing
    rpm -qs dbus.i386 | grep daemon

You should see the state "wrong color", meaning that rpm
chose to install the ELF64, not the ELF32, executable.

Uninstalled files are skipped with --verify.

NOTABUG
Comment 2 Jan Kratochvil 2006-09-12 03:34:07 EDT
Oops, I missed this option, I even searched for such one, thanks.

Note You need to log in before you can comment on or make changes to this bug.