Bug 206039 - Error when partitioning disks for LVM
Error when partitioning disks for LVM
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-11 13:20 EDT by Aleksandar Milivojevic
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 19:11:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksandar Milivojevic 2006-09-11 13:20:12 EDT
Description of problem:
When doing kickstart installation, I'm getting error that "logical volume must
be larger than physical extent size".  The part of kickstart script that defines
partitions looks like this:

clearpart --initlabel --drives=sda
part /boot --size 256 --ondisk sda --asprimary
part pv.00 --size 1 --grow --ondisk sda --asprimary
volgroup sys pv.00
logvol / --name root --vgname sys --fstype ext3 --size 1000
logvol swap --name swap --vgname sys --fstype swap --size 256
logvol /tmp --name tmp --vgname sys --fstype ext3 --size 64
logvol /var --name var --vgname sys --fstype ext3 --size 1000
logvol /srv --name srv --vgname sys --fstype ext3 --size 1 --grow

This above lines used to work just fine in RHEL4 and FC5.  The disk in question
is 4GB disk (virtual disk in vmware).

If I let Anaconda to autopartition the disk (using autopart instead of the above
lines), I can see it created physical volume with 32MB extent size.  So even my
smallest partition (/tmp) should be OK there.  Unless Anaconda is using
different default extent size for autoparitioning and for manual partitioning. 
I'm not aware of any kickstart option to force differnt extent size when
creating physical volume.

I also attempted chaning /tmp to 256MB, and got same error message.

BTW, any special reason for using big extent sizes (32MB) when creating physical
volumes in Anaconda?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lumens 2006-09-11 18:05:06 EDT
It's because of your /srv partition being specified as 1 MB, even though you say
to grow.  If you increase the minimum size there then everything should be fine.
 We should be handling this better in the next release, though.
Comment 2 Aleksandar Milivojevic 2006-09-11 23:51:52 EDT
Thanks for the quick answer.  If I got you right, the problem is that Anaconda
was doing the check on the size given in argument of --size option, instead of
checking what would be the actuall partition size?

Strange thing is that --size 1 --grow works on RHEL4 and FC5.  Could it be that
Anaconda in RHEL4 and FC5 is not doing this check at all?
Comment 3 Chris Lumens 2006-09-12 10:46:00 EDT
Right, this check is a new thing.  I've been trying to make kickstart error
messages more useful and this is an instance of one of those.  Unfortunately, I
wasn't taking the --grow option into account here so it's just a comparison
between the PE size and the size specified for the logical volume.
Comment 5 RHEL Product and Program Management 2006-10-26 16:17:31 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 6 Aleksandar Milivojevic 2006-11-30 16:48:11 EST
I've retested with RHEL5 beta 2 and it seems that the issue is resolved.
Comment 7 RHEL Product and Program Management 2006-12-22 19:11:54 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.