Bug 20604 - texi2html is out of date
texi2html is out of date
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
http://www.mathematik.uni-kl.de/~obac...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-09 14:53 EST by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-10 18:39:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-09 14:53:12 EST
The texi2html 1.56k program distributed with your tetex-1.0.7-7 package is
out of date.  The most recent version is 1.64 and has significantly more
functionality.  It is available from
http://www.mathematik.uni-kl.de/~obachman/Texi2html/ .
Comment 1 Need Real Name 2000-11-10 18:02:57 EST
There is at least one bug in texi2html 1.64, but most of it works better (more
tex command support, better formatting, etc.) than 1.56k.  The bug I discovered
is that the "FastBack" links generated in the HTML navbars are broken and
perform a "FastForward" action.
Comment 2 Need Real Name 2000-11-10 18:39:28 EST
Re: the previous comment, I discovered this bug while generating docs from the
CVS 1.11 source.  There is an example of the HTML generated from the cvs.texinfo
file browsable at http://cvshome.org/docs/manual/cvs_toc.html (some of the "Up"
links are broken in that document, but that is our (CVSHome & OpenAvenue's)
fault and should be fixed shortly) or downloadable from:
http://alumni.engin.umich.edu/~oberon/cvs1-11.html.tgz and
http://alumni.engin.umich.edu/~oberon/cvs1-11.html.tar.bz2 .  The CVS 1.11
source, of course, with the cvs.texinfo file mentioned above, is available in
tgz and srpm format from http://cvshome.org .

I made one very minor change to cvs.texinfo file before creating the HTML, but
the same bug seems to be reproducible in the HTML I can generate without the
change, so this should be irrelevant.

If you can't reproduce the bug yourself, of course, feel free to request a copy
of the offending files, or indeed, any other information from me.

I have reported this bug to texi2html@mathematik.uni-kl.de already and recieved
little response.

There was a new thread on the texi2html@mathematik.uni-kl.de mailing list today
as well regarding the ability of texi2html 1.64 to pass the HTML validation
tests available at <http://validator.w3.org/>, but I am currently unsure of the
import of this and as far as I know the HTML generated is viewable by Netscape
4.76 & recent version of MS Explorer.
Comment 3 Jeff Johnson 2000-12-27 15:38:06 EST
Upgraded to texi2html-1.64 in tetex-1.0.7-9. Thanks for the detailed explanation
and pointers.

Note You need to log in before you can comment on or make changes to this bug.