Bug 206042 - lvm_t disallowed write/getattr for lvm_etc_t
lvm_t disallowed write/getattr for lvm_etc_t
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-09-11 13:34 EDT by Jeremy Katz
Modified: 2008-10-20 10:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-11 16:35:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2006-09-11 13:34:30 EDT
The lvm tools aren't being allowed write or getattr perms for lvm_etc_t -- I
expect that we probably do want to allow this (or alternately, /etc/lvm/.cache
should be labeled differently)

This leads to SELinux avcs on kernel upgrades
Comment 1 Daniel Walsh 2006-09-11 16:26:31 EDT
This should be labeled lvm_medata_t

ls -lZ /etc/lvm/.cache 
-rw-------  root root system_u:object_r:lvm_metadata_t /etc/lvm/.cache

Any idea how this got mislabeled?  Did you recreate the file without using lvm
tools?
Comment 2 Jeremy Katz 2006-09-11 16:35:05 EDT
Not that I know of.  But since I've only seen it on my laptop, I'm willing to
believe it's something spurious to do with how I go through rawhide daily ;)

Note You need to log in before you can comment on or make changes to this bug.