This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 206060 - crashes on startup
crashes on startup
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: alacarte (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-09-11 15:16 EDT by Bill Nottingham
Modified: 2014-03-16 23:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-07 16:02:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 355808 None None None Never

  None (edit)
Description Bill Nottingham 2006-09-11 15:16:27 EDT
[notting@apone: ~]$ alacarte 
Traceback (most recent call last):
  File "/usr/bin/alacarte", line 36, in ?
    main()
  File "/usr/bin/alacarte", line 32, in main
    app = MainWindow(datadir, version, sys.argv)
  File "/usr/lib/python2.4/site-packages/Alacarte/MainWindow.py", line 45, in
__init__
    self.editor = MenuEditor()
  File "/usr/lib/python2.4/site-packages/Alacarte/MenuEditor.py", line 36, in
__init__
    self.__loadMenus()
  File "/usr/lib/python2.4/site-packages/Alacarte/MenuEditor.py", line 42, in
__loadMenus
    self.applications.path = os.path.join(util.getUserMenuPath(),
self.applications.tree.get_menu_file())
  File "/usr/lib/python2.4/site-packages/Alacarte/util.py", line 132, in
getUserMenuPath
    os.makedirs(menu_dir)
  File "/usr/lib64/python2.4/os.py", line 159, in makedirs
    mkdir(name, mode)
OSError: [Errno 20] Not a directory: '/home/devel/notting/.config/menus'
[notting@apone: ~]$ rpm -q alacarte
alacarte-0.10.0-1.fc6
Comment 1 Matthias Clasen 2006-09-12 00:01:05 EDT
does not happen here. 
What is ~/.config/menus, if not a directory ?
Comment 2 Bill Nottingham 2006-09-12 00:29:24 EDT
[notting@devserv: ~]$ cd ~/.config
-bash: cd: /home/devel/notting/.config: Not a directory

The parent dir isn't there...
Comment 3 Matthias Clasen 2006-09-12 10:10:12 EDT
if I rm -rf ~/.config and run alacarte, it works fine...
Comment 4 Bill Nottingham 2006-09-12 11:29:45 EDT
Whoops, that's what I get for commenting at midnight. 

.config is a regular file.
Comment 5 Matthias Clasen 2006-09-12 15:19:49 EDT
Hardly a blocker bug, unless some other tool we ship creates a $HOME/.config 
file. Of course, alacarte could handle this nicer...
Comment 6 Bill Nottingham 2006-09-12 15:36:05 EDT
What does it use this for - what is it storing?

Is this part of a xdg-ish standard, or alacarte-specific?
Comment 7 Matthias Clasen 2006-09-12 17:13:01 EDT
part of the basedir spec, which talks about things like
XDG_DATA_DIRS, XDG_DATA_HOME, etc
Comment 8 Ray Strode [halfline] 2007-03-06 13:38:20 EST
Do you have any idea how the file got created?

Was it some kernel .config file laying around?  

Maybe we should pop up a dialog and say something like "In order to successfully
edit menus, there needs to be a folder in your home directory called '%s'. 
Unfortunately, there is a file with that name in the way.  Would you like to
rename the file to '%s'?

[Quit] [Rename Conflicting File]

well something roughly like that anyway.
Comment 9 Bill Nottingham 2007-03-07 15:41:15 EST
Yeah, it was a random kernel .config file. I dunno, I suppose this is probably
an upstream bug at this point.
Comment 10 Ray Strode [halfline] 2007-03-07 16:02:28 EST
ah looks like it already got fixed upstream too.

Note You need to log in before you can comment on or make changes to this bug.