Bug 206082 - i810: xen kernel / firstboot causes machine to freeze
i810: xen kernel / firstboot causes machine to freeze
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11 (Show other bugs)
5.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-11 16:52 EDT by Bernard Johnson
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 19:12:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
configuration file (757 bytes, text/plain)
2006-09-16 02:02 EDT, Bernard Johnson
no flags Details
X startup log (45.31 KB, text/plain)
2006-09-16 02:04 EDT, Bernard Johnson
no flags Details
xorg config file for Radeon (803 bytes, text/plain)
2006-12-03 01:37 EST, Bernard Johnson
no flags Details
xorg log file for Radeon (43.24 KB, text/plain)
2006-12-03 01:40 EST, Bernard Johnson
no flags Details

  None (edit)
Description Bernard Johnson 2006-09-11 16:52:45 EDT
Description of problem:
On a freshly installed system, firstboot causes a system freeze requiring a hard
power off.  No messages are in the system logs to determine the cause.  Booting
single-user and disabling firstboot will work around the problem.


Version-Release number of selected component (if applicable):
firstboot-1.4.18-1
kernel-xen-2.6.17-1.2519.4.21.el5

How reproducible:
Always

Steps to Reproduce:
1. Reboot freshly installed system.
2. Wait for firstboot
3.
  
Actual results:
System freezes when firstboot is run on a freshly installed system.

Expected results:
Normal firstboot procedure.

Additional info:
Comment 1 Bernard Johnson 2006-09-11 17:11:07 EDT
This does not happen with the non-xen kernel.
Comment 2 Adam Jackson 2006-09-15 17:02:30 EDT
Can you attach the X config file and startup log from an affected system?
Comment 3 Bernard Johnson 2006-09-16 02:02:35 EDT
Created attachment 136410 [details]
configuration file
Comment 4 Bernard Johnson 2006-09-16 02:04:57 EDT
Created attachment 136411 [details]
X startup log
Comment 5 Bernard Johnson 2006-09-16 02:07:16 EDT
I will be out of town until Sep 23.  If you need more information, let me know
and I'll provide it when I return.  Thanks.
Comment 7 RHEL Product and Program Management 2006-10-26 16:16:44 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 8 Adam Jackson 2006-11-13 09:28:52 EST
Please verify that this bug still exists in xorg-x11-server 1.1.1-48.2.el5 or
later (available in Beta2).  A major bug was fixed regarding the interaction of
Xen with the processor's vm86 mode, which is used to initialize video and which
is handled differently between normal and Xen-enabled kernels.
Comment 9 Bernard Johnson 2006-11-17 16:35:35 EST
I installed beta2 and it does not crash at firstboot.

I did see what appeared to be a python stack trace on when firstboot ran (while
still in text mode), but I was unable to capture any information and the logs
did not contain it.
Comment 10 Bernard Johnson 2006-11-21 16:47:19 EST
Please check bug #216766 for a regression before closing.  Thanks.
Comment 11 Leslie Satenstein 2006-12-02 20:46:21 EST
Although I am using Fedora 6xen, the problem is exacerbated by the fact that
now, the lockup as described is occurring randomly. Sometimes on a boot,
sometimes on a logout, and sometimes hours after a login. Concerning Fedora, I
have determined that the problem appears to be linked to one of 3 files namely:
updated xorg-x11-drv-i810 packages
updated xorg-x11-server packages
updated xorg-x11-xinit 
Possibly, there is an ATI package that may be implicated. It was posted to core
at the same time    xorg-x11-drv-ati packages

This problem disappears entirely if the driver is switched from i810 to vesa in
the /etc/X11/xorg.conf file 


Comment 12 Bernard Johnson 2006-12-03 01:33:41 EST
On Leslie's comment #11, I installed Xen on my FC6 notebook computer with an ATI
Radeon P24 1P [Radeon Mobility X600].  On this computer there are two problems:

1) There is no output whatsoever between grub and rhgb.
2) The system reboots when rhbg hits firstboot

kernel-xen-2.6.18-1.2849.fc6
xorg-x11-server-Xorg-1.1.1-47.1.fc6

Log and config to follow.
Comment 13 Bernard Johnson 2006-12-03 01:37:04 EST
Created attachment 142674 [details]
xorg config file for Radeon
Comment 14 Bernard Johnson 2006-12-03 01:40:31 EST
Created attachment 142675 [details]
xorg log file for Radeon
Comment 16 Adam Jackson 2006-12-15 12:42:58 EST
Closing, x86emu in X appears to be as correct as it's going to get without
fixing the kernel.  
Comment 17 RHEL Product and Program Management 2006-12-22 19:12:07 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.