This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 206105 - "INFO: possible recursive locking detected" in device-mapper
"INFO: possible recursive locking detected" in device-mapper
Status: CLOSED DUPLICATE of bug 204311
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
Brian Brock
:
: 208335 (view as bug list)
Depends On:
Blocks: FCMETA_LOCKDEP
  Show dependency treegraph
 
Reported: 2006-09-12 02:02 EDT by Thorsten Leemhuis
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-05 11:07:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2006-09-12 02:02:39 EDT
Description of problem:
During each boot I see this:

[...]
libata version 2.00 loaded.
device-mapper: ioctl: 4.7.0-ioctl (2006-06-24) initialised: dm-devel@redhat.com

=============================================
[ INFO: possible recursive locking detected ]
2.6.17-1.2630.fc6 #1
---------------------------------------------
init/1 is trying to acquire lock:
 (&md->io_lock){----}, at: [<ffffffff880ed654>] dm_request+0x25/0x130 [dm_mod]

but task is already holding lock:
 (&md->io_lock){----}, at: [<ffffffff880ed654>] dm_request+0x25/0x130 [dm_mod]

other info that might help us debug this:
1 lock held by init/1:
 #0:  (&md->io_lock){----}, at: [<ffffffff880ed654>] dm_request+0x25/0x130 [dm_mod]

stack backtrace:

Call Trace:
 [<ffffffff8026e97d>] show_trace+0xae/0x336
 [<ffffffff8026ec1a>] dump_stack+0x15/0x17
 [<ffffffff802a844c>] __lock_acquire+0x135/0xa64
 [<ffffffff802a931e>] lock_acquire+0x4b/0x69
 [<ffffffff802a5dfb>] down_read+0x3e/0x4a
 [<ffffffff880ed654>] :dm_mod:dm_request+0x25/0x130
 [<ffffffff8021cf27>] generic_make_request+0x21a/0x235
 [<ffffffff880ec402>] :dm_mod:__map_bio+0xca/0x104
 [<ffffffff880ece48>] :dm_mod:__split_bio+0x16a/0x36b
 [<ffffffff880ed74c>] :dm_mod:dm_request+0x11d/0x130
 [<ffffffff8021cf27>] generic_make_request+0x21a/0x235
 [<ffffffff80235e72>] submit_bio+0xd3/0xdc
 [<ffffffff8021b363>] submit_bh+0x100/0x124
 [<ffffffff802e22c2>] block_read_full_page+0x283/0x2a1
 [<ffffffff802e4aae>] blkdev_readpage+0x13/0x15
 [<ffffffff80213573>] __do_page_cache_readahead+0x17b/0x1fc
 [<ffffffff80234deb>] blockable_page_cache_readahead+0x5f/0xc1
 [<ffffffff8021476c>] page_cache_readahead+0x146/0x1bb
 [<ffffffff8020c2ba>] do_generic_mapping_read+0x157/0x4b4
 [<ffffffff8020c772>] __generic_file_aio_read+0x15b/0x1b1
 [<ffffffff802c8c5a>] generic_file_read+0xc6/0xe0
 [<ffffffff8020b615>] vfs_read+0xcc/0x172
 [<ffffffff80212194>] sys_read+0x47/0x6f
 [<ffffffff8026060e>] system_call+0x7e/0x83
DWARF2 unwinder stuck at system_call+0x7e/0x83
Leftover inexact backtrace:

usb 2-1: new low speed USB device using ohci_hcd and address 2
[...]

Doesn't do any harm here, system works fine afterwards. 

Version-Release number of selected component (if applicable):
2.6.17-1.2630.fc6

How reproducible:
Always
Comment 1 Alasdair Kergon 2006-09-13 15:12:52 EDT
A known problem (on lkml in July) but we haven't fixed it yet.
Comment 2 Peter Zijlstra 2006-09-28 04:47:07 EDT
*** Bug 208335 has been marked as a duplicate of this bug. ***
Comment 3 Alasdair Kergon 2006-10-05 11:07:27 EDT

*** This bug has been marked as a duplicate of 204311 ***

Note You need to log in before you can comment on or make changes to this bug.