Bug 206120 - scim-chewing: keep clicking after pre-edit word makes gedit crash
scim-chewing: keep clicking after pre-edit word makes gedit crash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim-chewing (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caius Chance
: i18n
Depends On:
Blocks: 209575
  Show dependency treegraph
 
Reported: 2006-09-12 04:53 EDT by Xiaohong Wang
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: scim-chewing-0.3.1-9.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-12 01:31:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (419.92 KB, image/png)
2006-09-12 04:53 EDT, Xiaohong Wang
no flags Details
details (9.31 KB, text/plain)
2006-09-12 04:54 EDT, Xiaohong Wang
no flags Details
gdb gedit info (2.23 KB, text/plain)
2006-09-14 05:43 EDT, Xiaohong Wang
no flags Details
gdb backtrace when the Bug Buddy windows pops up. (732 bytes, text/plain)
2006-09-14 20:14 EDT, Caius Chance
no flags Details
gdb gedit info (2.80 KB, text/plain)
2006-10-11 04:20 EDT, Xiaohong Wang
no flags Details

  None (edit)
Description Xiaohong Wang 2006-09-12 04:53:49 EDT
Description of problem:


Version-Release number of selected component (if applicable):
scim-chewing-0.3.1-4.fc6

How reproducible:
always

Steps to Reproduce:
1.activate scim-chewing, ctrl-SPACE
2.launch gedit and enter ji3+Enter+ji3 (我我)
3.double-click several times after the second word 我
  
Actual results:
application crashed, pls see attached screenshot and details

Expected results:


Additional info:
Comment 1 Xiaohong Wang 2006-09-12 04:53:50 EDT
Created attachment 136060 [details]
screenshot
Comment 2 Xiaohong Wang 2006-09-12 04:54:56 EDT
Created attachment 136061 [details]
details
Comment 3 Xiaohong Wang 2006-09-12 05:02:38 EDT
And in oowriter, keep clicking after pre-edit word would clear all characters
before this word
Comment 4 Xiaohong Wang 2006-09-14 05:43:54 EDT
Created attachment 136246 [details]
gdb gedit info
Comment 5 Caius Chance 2006-09-14 20:12:47 EDT
It should not be the scim-problem but is gedit problem.

Attached scim-chewing (`gdb` -> attach process of scim-launcher), but it has not
crashed even gedit pop up a Bug Buddy window.

BTW, it is not reproduceable in gnome terminal and other gtk+ applications like
gaim.

-----

Change component to gedit.
Comment 6 Caius Chance 2006-09-14 20:14:21 EDT
Created attachment 136316 [details]
gdb backtrace when the Bug Buddy windows pops up.
Comment 7 Matthias Clasen 2006-09-15 11:14:45 EDT
Xiaohong, can you reproduce the same gedit stacktrace after installing 
gtk2-debuginfo and gtksourceview-debuginfo, please ?
Comment 8 Leon Ho 2006-09-28 01:44:45 EDT
Can you assist on Matthias' request please? install appropriate *-debuginfo for
symbols.

Also do other scim IMEs crash in the same way?
Comment 9 Xiaohong Wang 2006-10-11 04:19:00 EDT
After installed gtk2-debuginfo and gtksourceview-debuginfo, ran gdb and did same
steps to reproduce the bug, gedit didn't crash but got frozen.

Installed packages are...
gtk2-debuginfo-2.10.4-4.fc6
gtksourceview-debuginfo-1.8.0-1.fc6
scim-1.4.4-35.fc6
scim-debuginfo-1.4.4-35.fc6
scim-chewing-0.3.1-7.fc6
scim-chewing-debuginfo-0.3.1-7.fc6
gedit-2.15.9-1.fc6
gedit-debuginfo-2.15.9-1.fc6

And it seems that other scim IMEs couldn't crash in the same way.
Comment 10 Xiaohong Wang 2006-10-11 04:20:45 EDT
Created attachment 138224 [details]
gdb gedit info
Comment 11 Caius Chance 2006-10-25 00:58:14 EDT
The problem is not reproduceable on oowriter:

openoffice.org-langpack-ko_KR-2.0.4-5.3
openoffice.org-graphicfilter-2.0.4-5.3
openoffice.org-langpack-pa_IN-2.0.4-5.3
openoffice.org-langpack-zh_TW-2.0.4-5.3
openoffice.org-xsltfilter-2.0.4-5.3
openoffice.org-langpack-ja_JP-2.0.4-5.3
openoffice.org-calc-2.0.4-5.3
openoffice.org-draw-2.0.4-5.3
openoffice.org-core-2.0.4-5.3
openoffice.org-langpack-hi_IN-2.0.4-5.3
openoffice.org-impress-2.0.4-5.3
openoffice.org-langpack-ta_IN-2.0.4-5.3
openoffice.org-langpack-zh_CN-2.0.4-5.3
openoffice.org-math-2.0.4-5.3
openoffice.org-writer-2.0.4-5.3
Comment 12 Jens Petersen 2006-10-30 21:24:52 EST
Problem happens with gtktextview and other scim IMEs in general, and does not seem
to be gedit or scim-chewing specific.  Also happens with both scim and scim-bridge
im modules.
Comment 13 Jens Petersen 2006-11-01 21:02:05 EST
(In reply to comment #12)
> does not seem to be [..] scim-chewing specific

Actually testing further on my own rhel5 testbox yesterday , I could only
reproduce this with scim-chewing.
Comment 14 Jens Petersen 2006-11-02 03:10:50 EST
After testing more with Caius, it seems there may be two issues: Caius has been
testing with the scim gtkimm whereas I am using the scim-bridge immodule.

With the scim gtkimm clicking does not always reset preedit, whereas it does with
the scim-bridge gtkimm.  Hence one sees preedit movement and sometimes crashing
with the scim gtkimm but not scim-bridge for other IMEs too.  However scim-chewing
crashes under both scim and scim-bridge gtkimms, so it seems to be an additional
problem.

So probably a separate bug should be opened for scim for the lack of reset on
click.
Comment 15 Caius Chance 2006-11-07 20:29:55 EST
When scim-bridge trigger reset, it will call reset() in scim-chewing.

Added scim-chewing will call focus_out and focus_in when reset is triggered,
preedit will be cleared that avoid gedit crashes.

Patched and built. Pending for QA.
Comment 16 Ramakrishna Reddy Yekulla 2007-01-12 01:31:32 EST
Environment Setup ::
1. rpm -qa --qf "%{name}-%{version}-%{release}.%{arch}\n" scim\* | sort
2. scim-chewing-0.3.1-9.fc7.x86_64
3. gedit-2.15.9-1.fc6

Packages version number ::
scim-1.4.5-7.fc7.x86_64
scim-anthy-1.2.2-1.fc7.x86_64
scim-bridge-0.4.9-1.fc7.x86_64
scim-bridge-gtk-0.4.9-1.fc7.i386
scim-bridge-gtk-0.4.9-1.fc7.x86_64
scim-bridge-qt-0.4.9-1.fc7.x86_64
scim-chewing-0.3.1-9.fc7.x86_64
scim-devel-1.4.5-7.fc7.i386
scim-devel-1.4.5-7.fc7.x86_64
scim-doc-1.4.5-7.fc7.x86_64
scim-fcitx-3.1.1-6.fc6.x86_64
scim-fcitx-tools-3.1.1-6.fc6.x86_64
scim-hangul-0.2.2-7.fc6.x86_64
scim-input-pad-0.1.1-7.fc7.x86_64
scim-libs-1.4.5-7.fc7.i386
scim-libs-1.4.5-7.fc7.x86_64
scim-m17n-0.2.1-1.fc7.x86_64
scim-pinyin-0.5.91-16.fc7.x86_64
scim-qtimm-0.9.4-5.i386
scim-qtimm-0.9.4-5.x86_64
scim-sinhala-0.2.0-2.fc6.x86_64
scim-skk-0.5.2-8.fc6.x86_64
scim-tables-0.5.7-1.fc7.x86_64
scim-tables-additional-0.5.7-1.fc7.x86_64
scim-tables-amharic-0.5.7-1.fc7.x86_64
scim-tables-arabic-0.5.7-1.fc7.x86_64
scim-tables-chinese-0.5.7-1.fc7.x86_64
scim-tables-nepali-0.5.7-1.fc7.x86_64
scim-tables-russian-0.5.7-1.fc7.x86_64
scim-tables-thai-0.5.7-1.fc7.x86_64
scim-tables-vietnamese-0.5.7-1.fc7.x86_64
scim-tomoe-0.4.0-1.fc7.x86_64



Steps to reproduce ::
1.rpm -qa --qf "%{name}-%{version}-%{release}.%{arch}\n" scim\* | sort
o Applications --> Accessories -> Terminal
o Applications --> Accessories --> Text Editor
o 1.activate scim-chewing, ctrl-SPACE
o launch gedit and enter ji3+Enter+ji3 (我我)
o double-click several times after the second word 我
After following the steps to reproduce mentioned in the original bug. After
ji3+Enter+ji3 It is not crashing gedit.

Observation ::
Followed the steps mentioned in Comment #1. gedit is not crashing.

Note You need to log in before you can comment on or make changes to this bug.