Bug 206121 - Incremental backup copies too much
Incremental backup copies too much
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: tar (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Ben Levenson
http://lists.gnu.org/archive/html/bug...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-12 04:54 EDT by Göran Uddeborg
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-15 09:58:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for the spec file (508 bytes, patch)
2006-09-12 06:20 EDT, David Juran
no flags Details | Diff
updated makeCheck patch (381 bytes, patch)
2006-09-12 06:21 EDT, David Juran
no flags Details | Diff

  None (edit)
Description Göran Uddeborg 2006-09-12 04:54:26 EDT
Description of problem:
When tar 1.15.90 does an incremental backup, it copies too much.  If any file
has been added to (or removed from) a directory, ALL files in that directory are
copied.  Depending on the directory, that could mean way too much data.

Version-Release number of selected component (if applicable):
tar 1.15.90

How reproducible:
Every time

Steps to Reproduce:
1. mkdir t
2. touch t/apa t/bepa
3. tar --create --listed-incremental=t.snap --verbose --file=t.tar t
(This will archive t/, t/apa, and t/bepa as expected.)
4. touch t/cepa
5. tar --create --listed-incremental=t.snap --verbose --file=t.tar t
  
Actual results:
Tar will (re)archive all files in t:

t/
t/apa
t/bepa
t/cepa

Expected results:
Only the new file should be archived:

t/
t/cepa

Additional info:
In the next upstreams version, 1.15.91, this is fixed.  I would suggest an upgrade.

Both FC5 and the latest test relase for FC6, 5.91, has tar 1.15.90.
Comment 1 David Juran 2006-09-12 06:20:30 EDT
Created attachment 136064 [details]
patch for the spec file

Attached is a patch to the spec file for upgrading tar in rawhide to 1.15.91. 
The makeCheck patch had to be slightly modified to apply to the new source
(though  lacking a s390 I can't vouch for if it's still needed) and I dropped
the permissions-patch since it had been incorporated upstreams.
Comment 2 David Juran 2006-09-12 06:21:29 EDT
Created attachment 136065 [details]
updated makeCheck patch

Note You need to log in before you can comment on or make changes to this bug.