Bug 2061440 - bcm283x-firmware fails to boot on 32-bit arm
Summary: bcm283x-firmware fails to boot on 32-bit arm
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bcm283x-firmware
Version: 36
Hardware: armv7l
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F36BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2022-03-07 15:25 UTC by Paul Whalen
Modified: 2022-03-10 07:04 UTC (History)
5 users (show)

Fixed In Version: bcm283x-firmware-20220301-1.f47c013.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-10 07:04:11 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Paul Whalen 2022-03-07 15:25:12 UTC
Description of problem:
Attempting to boot recent builds of bcm283x-firmware fails to find U-boot and only displays a rainbow screen. 

Version-Release number of selected component (if applicable):
bcm283x-firmware-20220209-1.577aef2.fc36

How reproducible:
Every time

Additional info:

Commenting out the following lines in config.txt gets the system booting as expected. 

# Default Fedora configs for all Raspberry Pi Revisions
#[all]
#kernel=rpi-u-boot.bin

Comment 1 Fedora Blocker Bugs Application 2022-03-07 15:49:16 UTC
Proposed as a Blocker for 36-beta by Fedora user pbrobinson using the blocker tracking app because:

 Raspberry Pi is a blocking device

Comment 2 Geoffrey Marr 2022-03-07 22:03:50 UTC
Discussed during the 2022-03-07 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedBlocker (Beta)" was made as it violates the following criterion:

"All release-blocking images must boot in their supported configurations" for the release-blocking minimal image on the release-blocking 32-bit Raspberry Pi platform.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2022-03-07/f36-blocker-review.2022-03-07-17.01.txt

Comment 3 Fedora Update System 2022-03-08 11:44:25 UTC
FEDORA-2022-459cc6bd2b has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-459cc6bd2b

Comment 4 Fedora Update System 2022-03-08 16:18:38 UTC
FEDORA-2022-459cc6bd2b has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-459cc6bd2b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-459cc6bd2b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2022-03-10 07:04:11 UTC
FEDORA-2022-459cc6bd2b has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.