This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 206157 - Random openal crashes on x86_64
Random openal crashes on x86_64
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openal (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-12 11:27 EDT by Jerry James
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-07 11:45:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jerry James 2006-09-12 11:27:09 EDT
Description of problem:
I have observed this problem with scorched3d.  Bug 203336 indicates that it also
affects TORCS.  Until the last openal update, scorched3d worked fine on my
system, an x86_64 platform with an on-motherboard ICH7 sound system.  Now
scorched3d cannot be played with the sound turned on.  It will run for a short
time, typically less than a minute, then crash.  When it crashes, this is the
backtrace:

(gdb) bt
#0  _alFloatMul (bpt=0x1e3cff8, sa=Variable "sa" is not available.
) at arch/i386/x86_floatmul.c:88
#1  0x0000003203d11d9b in _alSourceParamApply (src=0xe17658, nc=2, len=Variable
"len" is not available.
)
    at al_source.c:2912
#2  0x0000003203d0c18e in _alApplyFilters (cid=36864, sid=16390)
    at al_filter.c:420
#3  0x0000003203d0e004 in _alMixSources () at al_mixer.c:266
#4  0x0000003203d0f16a in async_mixer_iterate (dummy=Variable "dummy" is not
available.
) at al_mixer.c:1076
#5  0x0000003203d168eb in runThread (data=Variable "data" is not available.
) at al_threadlib.c:19
#6  0x0000003bb4606337 in start_thread (arg=Variable "arg" is not available.
) at pthread_create.c:274
#7  0x0000003bb3dcc38d in ?? () from /lib64/libc.so.6
#8  0x0000000000000000 in ?? ()

This only happens on the x86_64 platform.  I have a 32-bit x86 platform where it
works fine.

Version-Release number of selected component (if applicable):
openal-0.0.9-0.6.20060204cvs.fc5

How reproducible:
Always

Steps to Reproduce:
1. Start scorched3d on an x86_64 machine.
2. Make sure that sound is turned on.
3. Play, typically for less than one minute.
  
Actual results:
Scorched3d crashes, regardless of video settings.

Expected results:
Scorched3d should continue playing normally.

Additional info:
This bug has been spotted elsewhere, without resolution:
https://gna.org/bugs/?func=detailitem&item_id=6196
http://de.pastebin.ca/65876
Comment 1 Andreas Bierfert 2006-09-17 11:16:37 EDT
Hm, I wonder if this has to do with the latest upgrade and the patch that was
added... will investigate...
Comment 2 Andreas Bierfert 2006-11-05 17:17:21 EST
Could you retry with the latest version? newest scorched works for me.
Comment 3 Jerry James 2006-11-07 11:36:13 EST
It works for me, too.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.