Bug 206158 - UTS_RELEASE define missing in include/linux/version.h
UTS_RELEASE define missing in include/linux/version.h
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Don Zickus
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-12 11:28 EDT by Aleksandar Milivojevic
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-20 22:21:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksandar Milivojevic 2006-09-12 11:28:24 EDT
Description of problem:
I don't know if this is the change in the upstream kernel or ommision in RHEL5.
 Probably the former (in which case this isn't really a bug).  The 2.6.9 kernels
in RHEL4 have UTS_RELEASE defined.

While running vmware-config-tools.pl script (from ESX 3.0 packages), and
attempting to build vmware's modules, the script failed because UTS_RELEASE
define was missing from version.h kernel header file.  After readding it, the
script ran fine and built the modules.

Version-Release number of selected component (if applicable):
kernel-devel-2.6.17-1.2519.4.21.el5

How reproducible:
Always

Steps to Reproduce:
1. Attempt to run vmware-config-tools.pl
  
Actual results:


Expected results:


Additional info:
Comment 1 Jay Turner 2006-09-20 22:21:01 EDT
UTS_RELEASE has moved to linux/utsrelease.h
Comment 2 Chris Leighton 2006-11-13 23:57:16 EST
The issue might be worked around by adding the following line to the beginning
of the header file /usr/src/kernels/<version-rel-arch>/include/linux/version.h:

#include <linux/utsrelease.h>
Comment 3 Chris Leighton 2006-11-14 00:11:46 EST
Further to comment #2:
can be used with Fedora Core 5: kernel-2.6.18-1.2200.fc5, kernel-2.6.18-1.2239.fc5

Note You need to log in before you can comment on or make changes to this bug.