Bug 206203 - Rpm crashed on (invalid?) package
Rpm crashed on (invalid?) package
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-12 17:30 EDT by Søren Sandmann Pedersen
Modified: 2014-06-18 05:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 09:34:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Søren Sandmann Pedersen 2006-09-12 17:30:43 EDT
Description of problem:

rpm crashed when I attempted to install the soon-to-be attached package. Then I
tried again, and it crashed again. Then I tried once again; this time it just
hung forever.


Version-Release number of selected component (if applicable):

4.4.2-32 (the one that will be in fc6 test3, I believe)

I have only seen it once.

Additional info:

Log:

[ssp@localhost i386]$ sudo rpm -Uvh --force
compiz-0.0.13-0.25.20060817git.fc6.i386.rpm
error: rpmdbNextIterator: skipping h#    2481 Header SHA1 digest: BAD
Expected(e6731a836c8c6060756f7be5f382c548d05fb4a9) !=
(3eeca1e5551d956e72bf373ba879d1f16a67966c)
Segmentation fault
[ssp@localhost i386]$
[ssp@localhost i386]$ sudo rpm -Uvh --force
compiz-0.0.13-0.25.20060817git.fc6.i386.rpm
error: rpmdbNextIterator: skipping h#    2481 region trailer: BAD, tag
2037609573 type 1834972474 offset -1868720741 count 1668570994
Segmentation fault
[ssp@localhost i386]$ sudo rpm -Uvh --force
compiz-0.0.13-0.25.20060817git.fc6.i386.rpm
Segmentation fault
Comment 1 Jeff Johnson 2006-09-12 18:16:46 EDT
The hang is easy to fix. You *must* do
   rm f /var/lib/rpm/__db*
after every exceptional (like a segfault or a kill -9) termination
of rpm.

The package is failing sanity checks on tag values and is likely
boogered up because of how you (or someone else) copied the
package.

If you give me a ptr to the package, I'll fix the segfault and verify
exactly what is wrong with the package.
Comment 2 Jeff Johnson 2007-01-03 22:48:10 EST
No reproducer == NOTABUG
Comment 3 Panu Matilainen 2007-06-27 09:34:52 EDT
Unable to fix without a reproducer.

Note You need to log in before you can comment on or make changes to this bug.