Bug 206211 - Buildinstall leaves packages out of the pkgfile.
Buildinstall leaves packages out of the pkgfile.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-12 18:24 EDT by Rich O'Hare
Modified: 2008-04-24 10:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-24 10:44:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build script followed by buildinstall output & anaconda.log. (6.94 KB, text/plain)
2006-09-12 18:24 EDT, Rich O'Hare
no flags Details

  None (edit)
Description Rich O'Hare 2006-09-12 18:24:46 EDT
Description of problem:
  Buildinstall leaves packages out of the pkgfile.

Version-Release number of selected component (if applicable):
  anaconda-runtime-11.0.5-1

How reproducible:
  Everytime

Steps to Reproduce:
1. Run buildinstall against original, un-updated, FC5 RPMS.
   buildinstall --comp dist-$release.$date \
   --pkgorder $FCBASE/pkgfile.$date --version $release \
   --product 'Fedora Core' --release "Fedora Core $release" \
   --prodpath Fedora $FCBASE/$arch
2.
3.
  
Actual results:
Count the number of RPMS included in the pkgfile.$date. Only
1749 of the 2185 packages are included.

Expected results:
All 2185 packages should be in the pkgfile.

Additional info: build script and anaconda.log attached.
Note the build script completes without error, but the CD's which are produced 
fail when attempting to install the bootloader.
Comment 1 Rich O'Hare 2006-09-12 18:24:46 EDT
Created attachment 136122 [details]
build script followed by buildinstall output & anaconda.log.
Comment 2 Rich O'Hare 2006-09-13 12:54:10 EDT
It looks like it is actually the pkgorder python script that fails to include
all RPM packages.
Comment 3 Rich O'Hare 2006-09-13 17:06:15 EDT
I tried it on an x86_64 machine, and it worked. For some reason it does not work
on DELL PRECISION 380.
Comment 8 Jeff Moe (jebba) 2007-01-12 23:11:13 EST
I have seen this problem and can reproduce it by running pkgorder by hand. For
some reason, in my environment, if I run as root, it misses 10% of the packages
or so (the exact same packages every time). If I run it as my regular user, it
works correctly. This is true whether I use `su` or `su -`. I looked at `env`
and LANG and such were the same. Adding PATH:/usr/lib/anaconda-runtime, one of
the only significant differences in the `env` had no affect. I have 8,526
packages that I'm working with, so my environment is different...

The same problem is described in this thread:
https://www.redhat.com/archives/fedora-buildsys-list/2006-December/msg00015.html
Comment 9 Red Hat Bugzilla 2007-08-21 01:25:59 EDT
User pnasrat@redhat.com's account has been closed
Comment 10 Bug Zapper 2008-04-03 23:42:23 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 11 Joel Andres Granados 2008-04-24 10:44:10 EDT
We use yum for this now.

Note You need to log in before you can comment on or make changes to this bug.