Bug 206213 - terminate called after throwing an instance of 'gcn::Exception'
terminate called after throwing an instance of 'gcn::Exception'
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: manaworld (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Wart
Fedora Extras Quality Assurance
:
Depends On: 207167
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-12 18:46 EDT by Patrice Dumas
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-14 23:49:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tmw.log when the SIGABRT was received (192.67 KB, text/plain)
2006-09-12 18:50 EDT, Patrice Dumas
no flags Details

  None (edit)
Description Patrice Dumas 2006-09-12 18:46:44 EDT
Description of problem:

Here is what I get (running under gdb)

terminate called after throwing an instance of 'gcn::Exception'

Program received signal SIGABRT, Aborted.
[Switching to Thread -1209010480 (LWP 11360)]
0xb7f26402 in __kernel_vsyscall ()
(gdb) bt
#0  0xb7f26402 in __kernel_vsyscall ()
#1  0x006f2d40 in raise () from /lib/libc.so.6
#2  0x006f4591 in abort () from /lib/libc.so.6
#3  0x03214d20 in __gnu_cxx::__verbose_terminate_handler ()
   from /usr/lib/libstdc++.so.6
#4  0x03212805 in std::set_unexpected () from /usr/lib/libstdc++.so.6
#5  0x03212842 in std::terminate () from /usr/lib/libstdc++.so.6
#6  0x0321297a in __cxa_throw () from /usr/lib/libstdc++.so.6
#7  0x00dd1f68 in gcn::SDLInput::convertMouseButton ()
   from /usr/lib/libguichan_sdl.so.0
#8  0x00dd2290 in gcn::SDLInput::pushInput () from /usr/lib/libguichan_sdl.so.0
#9  0x080dc4b9 in Game::handleInput (this=0x909c000) at game.cpp:602
#10 0x080dd00b in Game::logic (this=0x909c000) at game.cpp:354
#11 0x080e53d9 in main (argc=Cannot access memory at address 0x2c60
) at main.cpp:665
#12 0x006dff2c in __libc_start_main () from /lib/libc.so.6
#13 0x08055541 in _start ()

I attach twm.log

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Patrice Dumas 2006-09-12 18:50:20 EDT
Created attachment 136123 [details]
tmw.log when the SIGABRT was received
Comment 2 Patrice Dumas 2006-09-12 18:51:22 EDT
I just entered the forest (coming from the desert) when this happened
Comment 3 Wart 2006-09-12 19:59:02 EDT
It looks like this problem might be in the guichan library.  If you install the
guichan-debuginfo package then it might give me more clues on where to look. 
Alternately, if you can point me to a core file then I can look it up myself.
Comment 4 Patrice Dumas 2006-09-14 16:16:41 EDT
Here is a backtrace. 

To create it, I went back and forth from the forest to the desert
3 or 4 time, until it crash (at that point I was back
in the desert).

Program received signal SIGABRT, Aborted.
[Switching to Thread -1208490288 (LWP 17656)]
0xb7fa5402 in __kernel_vsyscall ()
(gdb) bt
#0  0xb7fa5402 in __kernel_vsyscall ()
#1  0x007ddd40 in raise () from /lib/libc.so.6
#2  0x007df591 in abort () from /lib/libc.so.6
#3  0x03214d20 in __gnu_cxx::__verbose_terminate_handler ()
   from /usr/lib/libstdc++.so.6
#4  0x03212805 in std::set_unexpected () from /usr/lib/libstdc++.so.6
#5  0x03212842 in std::terminate () from /usr/lib/libstdc++.so.6
#6  0x0321297a in __cxa_throw () from /usr/lib/libstdc++.so.6
#7  0x00dd1f68 in gcn::SDLInput::convertMouseButton (this=0x8d8e388, button=6)
    at sdlinput.cpp:208
#8  0x00dd2290 in gcn::SDLInput::pushInput (this=0x8d8e388, event=
        {type = 5 '\005', active = {type = 5 '\005', gain = 0 '\0', state = 6 '\
006'}, key = {type = 5 '\005', which = 0 '\0', state = 6 '\006', keysym = {scanc
ode = 200 '�, sym = SDLK_UNKNOWN, mod = KMOD_NONE, unicode = 0}}, motion = {type
 = 5 '\005', which = 0 '\0', state = 6 '\006', x = 456, y = 375, xrel = 0, yrel 
= 0}, button = {type = 5 '\005', which = 0 '\0', button = 6 '\006', state = 1 '\
001', x = 456, y = 375}, jaxis = {type = 5 '\005', which = 0 '\0', axis = 6 '\00
6', value = 456}, jball = {type = 5 '\005', which = 0 '\0', ball = 6 '\006', xre
l = 456, yrel = 375}, jhat = {type = 5 '\005', which = 0 '\0', hat = 6 '\006', v
alue = 1 '\001'}, jbutton = {type = 5 '\005', which = 0 '\0', button = 6 '\006',
 state = 1 '\001'}, resize = {type = 5 '\005', w = 24576456, h = 0}, expose = {t
ype = 5 '\005'}, quit = {type = 5 '\005'}, user = {type = 5 '\005', code = 24576
456, data1 = 0x0, data2 = 0x0}, syswm = {type = 5 '\005', msg = 0x17701c8}})
---Type <return> to continue, or q <return> to quit---
    at sdlinput.cpp:132
#9  0x080dc4b9 in gcn::ImageLoader::~ImageLoader ()
#10 0x080dd00b in gcn::ImageLoader::~ImageLoader ()
#11 0x080e53d9 in std::_Deque_base<gcn::ClipRectangle, std::allocator<gcn::ClipR
ectangle> >::~_Deque_base$base ()
#12 0x007caf2c in __libc_start_main () from /lib/libc.so.6
#13 0x08055541 in gcn::Button::mousePress () at button.cpp:224
Comment 5 Wart 2006-09-19 15:55:06 EDT
The bug looks like a problem in the guichan library, which will be updated in
coordination the next manaworld update (BZ #207167).  I can't guarantee that the
update will fix this bug, but I hope so.
Comment 6 Wart 2006-10-14 23:49:48 EDT
I've updated manaworld to the newest 0.0.21 release which is built against a
newer guichan library.  Please reopen this bug if it is not fixed by these two
newer package releases.

Note You need to log in before you can comment on or make changes to this bug.