Bug 206241 - Missing Hanja fonts with default Korean system
Missing Hanja fonts with default Korean system
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-13 03:04 EDT by Jong Bae KO
Modified: 2013-01-09 20:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 02:44:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch based on current rawhide (20060913) (503 bytes, patch)
2006-09-13 03:32 EDT, Caius Chance
no flags Details | Diff

  None (edit)
Description Jong Bae KO 2006-09-13 03:04:08 EDT
Description of problem:
I installed only Korean Language, but many hanja font are missing.
It should included all Hanja fonts with Korean Language.
It shows rowcodes on F9 key(Hangul/Hanja convertion)
Because general user they install only korean.

Version-Release number of selected component (if applicable):
scim-hangul-0.2.2-7.fc6
scim-1.4.4-34.fc6

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
what about Japanese?
Is chinese fonts included?
Comment 1 Akira TAGOH 2006-09-13 03:11:12 EDT
Reassigning to the correct package.
Comment 2 Jong Bae KO 2006-09-13 03:26:57 EDT
Steps to Reproduce:
1.Install FC on Korean language(don't include other languages).
2.run "gedit" and type "rh"
3.press F9
Comment 3 Caius Chance 2006-09-13 03:32:25 EDT
Created attachment 136140 [details]
proposed patch based on current rawhide (20060913)

install fonts-chinese along with Korean support until upstream cover all hanja
in fonts-korean
Comment 4 Caius Chance 2006-09-13 21:57:49 EDT
Patch testing in progress.
Comment 6 Jong Bae KO 2006-09-18 00:11:35 EDT
fonts-chinises is installed, but still some letters are missing in Hangul/Hanja
convertion.
eg. 鷱  <-- "rh(고)"

Comment 7 Caius Chance 2006-09-18 00:31:23 EDT
The coverage of fonts are decided by the font, even fonts-chinese upstream could
not cover all Chinese characters at this stage.

Please supply the frequently used Chinese characters by Korean users, so I could
report that to upstream. There is very difficult for perfecting the
fonts-chinese or fonts-korean at acceptable consistency without contributions
from upstream.

-----

Please maintainer update comps.xml and close this bug.
Comment 8 Caius Chance 2006-09-18 02:44:23 EDT
It is not a bug as the Korean font has not covered such missing characters at
the moment.

At long-term objectives, we should have a Korean font which covers all the
Korean characters including Hangul and Hanja.

-----

comps.xml should not be patched as we should not force Korean user to read Hanja
with glyphs from Chinese fonts. It is their freedom to decide whether they need
to read it or not with Chinese fonts. If so, they could install fonts-chinese
anytime during anaconda or by yum/pirut, etc.

Note You need to log in before you can comment on or make changes to this bug.