Bug 2062660 - The input string via Input Method isn't renderred properly at the search box on Activities
Summary: The input string via Input Method isn't renderred properly at the search box ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: openqa AcceptedFreezeException Accept...
Depends On:
Blocks: F36BetaFreezeException F36FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2022-03-10 10:29 UTC by Akira TAGOH
Modified: 2022-04-05 00:16 UTC (History)
12 users (show)

Fixed In Version: mutter-42.0-3.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-04-05 00:16:46 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME gnome-shell issues 5219 0 None None None 2022-03-16 06:27:19 UTC
GNOME Gitlab GNOME mutter issues 2188 0 None None None 2022-03-22 13:18:28 UTC

Description Akira TAGOH 2022-03-10 10:29:03 UTC
Description of problem:
The search box at Activities can shows first character only on the preedit and committed strings but not updating preedit during typing.

Version-Release number of selected component (if applicable):
gnome-shell-42~rc-1.fc36.x86_64

How reproducible:
always

Steps to Reproduce:
1.Add Japanese(Anthy) Input source
2.Activate it through Super+space
3.type edhita at the search box for example

Actual results:
only "え" is renderred

Expected results:
"えでぃた" should be renderred

Additional info:
Once typing enter, "えでぃた" appears at the search box. so they are capable to input something through ibus. but the rendering isn't correct.

Comment 1 Adam Williamson 2022-03-16 06:13:08 UTC
Yeah, I can confirm this - openQA has been hitting it for weeks, I just hadn't got around to reporting it yet. In the openQA test we hit the keys y, a, m, a - which should enter やま and then let us complete it to 山 - but we only see 'y' appear in the search box: https://openqa.fedoraproject.org/tests/1176159#step/_graphical_input/11

Comment 2 Adam Williamson 2022-03-16 06:17:26 UTC
Sadly I can't tell from openQA exactly when this started, because some other bugs that happened *earlier* showed up and confused the record. But the last time the test passed was on Fedora-Rawhide-20220214.n.0 , and I managed to get the other bugs fixed and reach this bug for the first time with Fedora-Rawhide-20220305.n.0 , so it broke somewhere in that gap.

Comment 3 Adam Williamson 2022-03-16 06:25:37 UTC
Oddly, I just tested this on my own laptop (where I have US English keyboard layout and Anthy input method configured) and can't reproduce it. But openQA hits it every time. Not sure what the difference is.

Comment 4 Adam Williamson 2022-03-16 21:31:48 UTC
+4 Beta FE in https://pagure.io/fedora-qa/blocker-review/issue/676 , marking accepted.

Comment 5 Jens Petersen 2022-03-17 08:06:58 UTC
(In reply to Adam Williamson from comment #3)
> Oddly, I just tested this on my own laptop (where I have US English keyboard
> layout and Anthy input method configured) and can't reproduce it. But openQA
> hits it every time. Not sure what the difference is.

It seems not 100% reproducible - though I think I can hit it about 90% of the time or more in my VM.

Comment 6 Adam Williamson 2022-03-21 15:56:41 UTC
+3 in https://pagure.io/fedora-qa/blocker-review/issue/676 , marking accepted Final blocker.

Comment 7 Jens Petersen 2022-03-22 13:18:28 UTC
Moving to mutter to align with the current upstream issue:
https://gitlab.gnome.org/GNOME/mutter/-/issues/2188

Comment 8 Fedora Update System 2022-03-31 16:01:59 UTC
FEDORA-2022-566779da43 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-566779da43

Comment 9 Adam Williamson 2022-04-01 22:49:54 UTC
I confirmed the fix here myself.

Comment 10 Fedora Update System 2022-04-01 23:23:42 UTC
FEDORA-2022-566779da43 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-566779da43`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-566779da43

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Akira TAGOH 2022-04-04 05:43:26 UTC
Yes, works for me too. thanks for the update.

Comment 12 Fedora Update System 2022-04-05 00:16:46 UTC
FEDORA-2022-566779da43 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.