This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 206295 - GFS2: bad spinlock magic, gfs2_mmap
GFS2: bad spinlock magic, gfs2_mmap
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Russell Cattelan
Brian Brock
:
Depends On:
Blocks: 220052
  Show dependency treegraph
 
Reported: 2006-09-13 11:06 EDT by Jeremy Katz
Modified: 2009-05-27 23:31 EDT (History)
3 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-19 13:33:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2006-09-13 11:06:31 EDT
New oops, current rawhide (2.6.17-1.2630)

Kernel BUG at lib/list_debug.c:26─────────────────────────────────────┘         
invalid opcode: 0000 [1] SMP                                                    
last sysfs file: /block/xvda/dev                                                
CPU 0                                                                           
Modules linked in: dm_emc dm_round_robin dm_multipath dm_snapshot dm_mirror
dm_zero dm_mod xfs jfs reiserfs lock_nolock gfs2 ext3 jbd msdos raid456 xor
raid1 raid0 xenblk xennet iscsi_tcp libiscsi scsi_transport_iscsi sr_mod sd_mod
scsi_mod ide_cd cdrom ipv6 squashfs pcspkr loop nfs nfs_acl fscache lockd sunrpc
vfat fat cramfs
Pid: 601, comm: build-locale-ar Not tainted 2.6.17-1.2630.fc6xen #1
RIP: e030:[<ffffffff80330d00>]  [<ffffffff80330d00>] __list_add+0x24/0x68
RSP: e02b:ffff88000b847cd8  EFLAGS: 00010286
RAX: 0000000000000058 RBX: ffff88000b3494b0 RCX: ffff88000b846000
RDX: 0000000000000000 RSI: 0000000000000001 RDI: 0000000000000000
RBP: ffff88000b847d18 R08: ffffffff804c88b8 R09: 0000000000000000
R10: 0000000000000000 R11: 0000000000000000 R12: ffff88000b847d18
R13: ffffc2000010ab40 R14: 0000000000000000 R15: ffff88000b349490
FS:  0000000000000000(0063) GS:ffffffff8064e000(0000) knlGS:0000000000000000
CS:  e033 DS: 0000 ES: 0000
Process build-locale-ar (pid: 601, threadinfo ffff88000b846000, task
ffff880017524820)
Stack:  ffff880014ab0b50  ffffc200000ba000  ffff88000b847cf8  ffffffff882daf18 
 ffffc200000ba000  000002db000001f6  0000000000000000  0000000000000000 
 ffff88000b3494b0  ffffc2000010ab60 
Call Trace:
 [<ffffffff882daf18>] :gfs2:databuf_lo_before_commit+0xd3/0x522
 [<ffffffff882d9717>] :gfs2:gfs2_log_flush+0x11e/0x2d5
 [<ffffffff882eae25>] :gfs2:gfs2_trans_end+0x13f/0x176
 [<ffffffff882d6f07>] :gfs2:gfs2_glock_nq_atime+0x213/0x2a2
 [<ffffffff882dfaca>] :gfs2:gfs2_mmap+0x36/0x83
 [<ffffffff882d6e46>] :gfs2:gfs2_glock_nq_atime+0x152/0x2a2
 [<ffffffff8020de6b>] do_mmap_pgoff+0x49f/0x773
 [<ffffffff80262079>] _spin_unlock_irq+0x9/0x10
 [<ffffffff80223c42>] sys_mmap+0x89/0xc1
 [<ffffffff8025da05>] tracesys+0xa7/0xb2


Code: 0f 0b 68 c8 d8 47 80 c2 1a 00 48 8b 55 00 48 39 da 74 1b 48 
RIP  [<ffffffff80330d00>] __list_add+0x24/0x68
 RSP <ffff88000b847cd8>
 <0>BUG: spinlock cpu recursion on CPU#0, gfs2_logd/586 (Not tainted)
 lock: ffffc2000010aae0, .magic: dead4ead, .owner: build-locale-ar/601,
.owner_cpu: 0

Call Trace:
 [<ffffffff8020722e>] _raw_spin_lock+0x58/0xeb
 [<ffffffff882d920e>] :gfs2:gfs2_ail1_empty+0x23/0x9f
 [<ffffffff80298f07>] keventd_create_kthread+0x0/0x66
 [<ffffffff882ce250>] :gfs2:gfs2_logd+0x4b/0x10e
 [<ffffffff802839f3>] __wake_up_common+0x3e/0x68
 [<ffffffff80298f07>] keventd_create_kthread+0x0/0x66
 [<ffffffff882ce205>] :gfs2:gfs2_logd+0x0/0x10e
 [<ffffffff802335c8>] kthread+0xfe/0x132
 [<ffffffff8025e238>] child_rip+0xa/0x12
 [<ffffffff80298f07>] keventd_create_kthread+0x0/0x66
 [<ffffffff8025fee7>] thread_return+0x0/0xec
 [<ffffffff802334ca>] kthread+0x0/0x132
 [<ffffffff8025e22e>] child_rip+0x0/0x12
Comment 1 Kiersten (Kerri) Anderson 2006-11-22 16:57:59 EST
Installs need to work on gfs2 for GA.
Comment 2 Rob Kenna 2006-11-25 16:35:14 EST
Agreed.  This needs to be root installable for GA even though it's tech preview.
Comment 3 Russell Cattelan 2006-12-18 16:49:51 EST
I have been unable to reproduce this panic with the current
gfs2 code in RHEL5.

Quite a number of bugs have been fixed in GFS2 some of them mmap releated
so it is quite possible this problem has been fixed.

Marking with needinfo for now.
Comment 4 Jeremy Katz 2006-12-19 13:33:24 EST
Yeah, this one was gotten past a while ago and then bug 215088 was hit

Note You need to log in before you can comment on or make changes to this bug.