Bug 206317 - lam-mpi broken
lam-mpi broken
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lam (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brian Brock
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-13 12:56 EDT by Vaggelis Meintanis
Modified: 2008-04-07 15:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 15:55:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vaggelis Meintanis 2006-09-13 12:56:09 EDT
Description of problem:

After one of the latest updates (within the past month or so) lam has been
unable compile code on our systems.

Version-Release number of selected component (if applicable):

lam-7.1.2-1.fc5

How reproducible:

Every time

Steps to Reproduce:
1. run mpicc from command prompt
2.
3.
  
Actual results:

WARNING: mpicc expected to find liblammpio.* in /usr/lib64/lam
WARNING: MPI-2 IO support will be disabled
WARNING: mpicc expected to find liblamf77mpi.* in /usr/lib64/lam
WARNING: MPI Fortran support will be disabled
gcc: no input files

Similar output is obtained on i386 machines.

Expected results:

gcc: no input files

Additional info:
Comment 1 Doug Ledford 2006-10-09 16:37:29 EDT
I had to make some changes to lam for fc6, and in my testing it is finding the
libs just fine.  I'll backport those changes to fc5 when I a spare round tuit or
two.
Comment 2 Doug Ledford 2006-10-13 12:39:50 EDT
OK, a few things.  Lam and openmpi are designed to be alternatives for mpicc, so
if you have openmpi installed, mpicc may actually be pointing to it instead.  I
bring this up because the exact error messages you are quoting are whats
expected when you are using the openmpi mpicc and don't have the lam-libs
packages for all relevant archs installed (eg. both lam-libs x86_64 and i386 on
x86_64 machines).  So, I would check that.  In the meantime, I'm building lam
7.1.2-8.fc5 right now.  The same package works properly and finds all of its
libs properly on fc6 and so should work on fc5 as well.  It's built to be
installed alongside openmpi 1.1-6 or later (earlier versions of openmpi will
attempt to use a different method than lam for resolving which should be the
system wide default mpi implementation, so symlinks can easily get confused if
you don't have the right version of openmpi installed along side the right
version of lam...in the future this won't be a problem, but for lam-7.1.2-8 I
had to make the change which essentially results in a flag day needing a
simultaneous update of both lam and openmpi).  It is not sufficient to just
update these RPMs.  It would be best to deinstall the previous lam and install
the new one afterwards (for scriptlet reasons).  Once the packages are done
building, I'll place them at
http://people.redhat.com/dledford/Infiniband/lam/7.1.2/8.fc5 so that you can
verify they work on your machine.  The matching openmpi rpms will be in
http://people.redhat.com/dledford/Infiniband/openmpi/1.1/6.fc5
Comment 3 Vaggelis Meintanis 2006-10-13 14:56:51 EDT
Hi,

I had solved the problem by removing both the lam and lam-libs packages that yum
had updated and installed respectively and reverting to the single lam rpm that
shipped with FC5. I should note here that I hadn't tweaked the lam installation
in any way and I was using what anaconda gave me. That was the case in both my
64-bit and 32-bit machines. In both types the update caused the same problem.

I tried to uninstall all existing lam and openmpi packages, per your
instructions, and installed the newly built ones. I assume that you have
compacted the i386 and x86_64 libraries, because they have the same names and
rpm would complain when I tried to install them one after the other. I am not
sure I've done something wrong, but with:

lam-libs-7.1.2-8.fc5
lam-7.1.2-8.fc5
openmpi-1.1-6.fc5

and

openmpi-libs-1.1-6.fc5

in my system, I can't even do 'mpicc'. 'locate' (after the necessary updatedb)
will not find such a file in any directory.

If you feel I have messed up my installation, my old solution seems to work and
I can stick with that. I just thought I'd help a bit.
Comment 4 Doug Ledford 2006-10-13 16:34:26 EDT
No, the i386 and x86_64 libs are in different packages.  With the current Fedora
Core product, rpm knows that the same name is used on the different arches and
doesn't complain about installing two of them.  I suspect you could --force it
on your machine and it would do the right thing, but I'm not sure (I wouldn't
--force the base packages, aka lam or openmpi, but the libs and devel packages
you could).  As for the lack of mpicc, that's because it was moved into the
-devel packages.
Comment 5 Vaggelis Meintanis 2006-10-19 16:38:06 EDT
Sorry for taking some time to reply. Our machines were doing production runs
(with the 7.1.1-11 version of lam).

I have installed your new lam, openmpi, lam-devel and openmpi-devel packages for
the x86-64 architecture, as well as the corresponding libs for both i386 and
x86-64 and lam seems to be working as expected again.

I hope you will upload these packages to the update repositories.

Thank you for your help!
Comment 6 Bug Zapper 2008-04-03 23:42:58 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.