This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 206320 - X apps don't work after sudo
X apps don't work after sudo
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: sudo (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Ben Levenson
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-09-13 13:15 EDT by Jeremy Katz
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-22 09:00:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2006-09-13 13:15:31 EDT
With the changed xauth bits in FC6, trying to read ~/.Xauthority and "assuming"
that works as sudo has done in the past doesn't continue to work.
Comment 1 Tomas Mraz 2006-09-18 09:11:10 EDT
Does it mean that sudo su - and running X app from the shell doesn't work? This
probably never worked right.

Or that direct sudo Xapp doesn't work?
Comment 2 Karel Zak 2006-09-18 09:19:45 EDT
I think "sudo xapp" has never worked. See
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=164671#c4
Comment 3 Jeremy Katz 2006-09-18 13:09:22 EDT
It worked fine in FC5 (as long as you're sudo'ing on the local machine) as the
xauth cookie was readable and things worked.  Now that we do xauth based on user
(to avoid hostname changes breaking things), it's broken
Comment 4 Tomas Mraz 2006-09-20 10:43:32 EDT
Default sudoers file must be modified to contain 'XAUTHORITY' in the 'Defaults
env_keep' settings.

Problem solved.
Comment 5 Peter Vrabec 2006-09-21 04:52:46 EDT
thnx. Tomas, it's fixed in sudo-1.6.8p12-9
Comment 6 Peter Vrabec 2006-09-22 09:00:46 EDT
latest-pkg  dist-fc6 sudo
sudo-1.6.8p12-9 dist-fc6 pvrabec

Note You need to log in before you can comment on or make changes to this bug.