Bug 20633 - samba srpm doesnt create binaries.
samba srpm doesnt create binaries.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Dale Lovelace
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-10 02:07 EST by Henri Schlereth
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-27 12:57:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henri Schlereth 2000-11-10 02:07:37 EST
With samba-2.0.7-4.srpm.rpm 
rpm -ba samba.spec only compiles and installs but doesnt create srpm or rpms.
rpm -bb samba.spec does the same.
rpm -bs samba.spec does create the srpm.
rpm version is rpm-3.0.5-9.6x

I am perfectly willing to admit I may be doing something wrong, but if I am not, then something is wrong
either with rpm (doubtfully) or the spec file (likely). This is the third package I have ever built/re-built.
Comment 1 Bill Nottingham 2000-11-10 11:57:14 EST
Do you have the error messages from the build?
Comment 2 Henri Schlereth 2000-11-10 17:59:04 EST
Error messages as follows for rpm -ba samba.spec:

FIle not found by glob: /var/tmp/samba-root/usr/man/man8/smbmnt.8*
File not found by glob: /var/tmp/samba-root/usr/man/man8/smbmount.8*
File not found by glob: /var/tmp/samba-root/usr/man/man8/smbumount.8*
File not found: /var/tmp/samba-root/usr/bin/nmblookup
File not found: /var/tmp/samba-root/usr/bin/rpcclient
File not found: /var/tmp/samba-root/usr/bin/smbclient
File not found: /var/tmp/samba-root/usr/bin/smbspool
File not found: /var/tmp/samba-root/usr/bin/smbtar
File not found by glob: /var/tmp/samba-root/usr/man/man1/smbtar.1*
File not found by glob: /var/tmp/samba-root/usr/man/man1/smbclient.1*
File not found by glob:/var/tmp/samba-root/usr/man/man1/nmblookup.1*
File not found by glob: /var/tmp/samba-root/usr/man/man8/smbspool.8*
File not found: /var/tmp/samba-root/usr/bin/make_smbcodepage
File not found: /var/tmp/samba-root/usr/bin/make_unicodemap
File not found: /var/tmp/samba-root/usr/bin/testparm
File not found: /var/tmp/samba-root/usr/bin/testprns
File not found: /var/tmp/samba-root/usr/bin/make_printerdef
File not found by glob /var/tmp/samba-root/usr/man/man1/make_smbcodepage.1*
File not found by glob: /var/tmp/samba-root/usr/man/man1/make_unicodemap.1*
File not found by glob: /var/tmp/samba-root/usr/man/man1/testparm.1*
File not found by glob: /var/tmp/samba-root/usr/man/man1/testprns.1*
File not found by glob: /var/tmp/samba-root/usr/man/man5/smb.conf.5*
File not found by glob: /var/tmp/samba-root/usr/man/man5/lmhosts.5*

There were no other obvious errors otherwise.
Comment 3 Bill Nottingham 2000-11-13 00:43:18 EST
Part of that may be because you have the updated RPM installed, with
possible new FHS-compliant paths for man pages, etc.
Comment 4 Henri Schlereth 2000-11-13 12:53:07 EST
Yes, but shouldnt that work anyway? All I am seeing is that it is not creating
the usr/man or bin directories in the /var/tmp/build-root directory. I would
assume that
it uses that to install and build packages?
Bottom line is that this spec file was supposedly used to generate the 
samba/common/client binaries and it chokes. 
What additional tests can you reccommend. If I manually create the missing
build-root directories during the the process and creates the rpm's do I prove
my case?
As far as FHS compliance goes, it does create the end-target locations 
but not in the build-root directory.

Puzzled, but willing to test further.....

Henri
RHBT


Comment 5 Andrew Bartlett 2000-11-17 18:30:24 EST
The Man pages are not found becouse the MANPATH is not set in the specfile, and
these are being INSTALLED into the real system

Similarly the binaries are not being found and are likewise being INSTALLED into
the system.

I know becouse I now have smbd.old and freinds lying around my system.  
Comment 6 Henri Schlereth 2000-11-27 12:57:24 EST
Cross tested on a RH7.0 server install with rpm-4.0.4 with the same results.

Henri
Comment 7 Bill Nottingham 2000-11-28 00:52:01 EST
Confirmed. This is fixed in 7.0, however (the 7.0 SRPM builds fine on
6.2 with new RPM.)

Note You need to log in before you can comment on or make changes to this bug.