Bug 2063410 - Printer setting: can't scroll media size list
Summary: Printer setting: can't scroll media size list
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-control-center
Version: 36
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: gnome-sig
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedFreezeException AcceptedBlock...
Depends On:
Blocks: F36FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2022-03-12 10:38 UTC by Alessio
Modified: 2022-04-08 02:57 UTC (History)
7 users (show)

Fixed In Version: gnome-control-center-42.0-3.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-04-08 02:57:03 UTC
Type: Bug


Attachments (Terms of Use)
screenshot of cropped page size (1.13 MB, image/png)
2022-03-29 10:38 UTC, Kamil Páral
no flags Details
screenshot of cropped paper type (402.86 KB, image/png)
2022-03-29 10:40 UTC, Kamil Páral
no flags Details
Listed input devices (84.18 KB, image/png)
2022-03-31 11:17 UTC, Lukas Ruzicka
no flags Details
Listed output devices (38.09 KB, image/png)
2022-03-31 11:18 UTC, Lukas Ruzicka
no flags Details
Low resolution, high number of outputs, broken selection box (162.27 KB, image/png)
2022-03-31 18:22 UTC, Brandon Nielsen
no flags Details
Low resolution, buggy popup behavior, no scroll possible (83.86 KB, image/png)
2022-03-31 18:28 UTC, Brandon Nielsen
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME gnome-control-center issues 1704 0 None None None 2022-03-29 12:51:29 UTC

Description Alessio 2022-03-12 10:38:07 UTC
Upstream bug

https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/1704

In short, once configured, you can't select some paper size because you can't scroll the media size list.

Comment 1 Fedora Blocker Bugs Application 2022-03-12 10:47:23 UTC
Proposed as a Freeze Exception for 36-final by Fedora user alciregi using the blocker tracking app because:

 "Printing must work in release-blocking desktops on at least one printer using each of the following drivers:"

Ok, the printer itself works, but only if you are lucky enough that the media size appears in the list. But if the media size is the last one in the list, since you cannot scroll the list, probably the printer will output a wrong print.
(And ok, you can use the CUPS web page to select the correct media size).

Comment 2 Brandon Nielsen 2022-03-16 19:29:05 UTC
The "real" upstream issue is in GTK[0].

If nobody gets a chance to fix this (I'm looking at it now, but my time is limited), a common bugs note could be made that you can scroll the combo box by just hovering over it and using your mouse wheel.

You should also be able to make your selection with a keyboard but that seems buggy as well (keyboard selects in the combo box below the one you made your initial selection in if you started with the mouse, which may be intentional, tabbing through the options results in an endless stream of notification sounds if your authentication expired).

[0] - https://gitlab.gnome.org/GNOME/gtk/-/issues/3674

Comment 3 Geoffrey Marr 2022-03-28 19:50:24 UTC
Discussed during the 2022-03-28 blocker review meeting: [0]

The decision to classify this bug as a "RejectedFreezeException (Final)" was made as we'd sort of like to take this as it does affect printing from the Workstation live, but the fix looks like a bit too much major surgery to be comfortable during a freeze, and we suspect the practical impact is not too big as commonly-used sizes are likely to be near the top of the list.

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2022-03-28/f36-blocker-review.2022-03-28-16.00.txt

Comment 4 Kamil Páral 2022-03-29 10:38:20 UTC
Created attachment 1868937 [details]
screenshot of cropped page size

(In reply to Geoffrey Marr from comment #3)
> as commonly-used sizes are likely to be near the top of the list.

That was a wrong assumption, folks :) Please see the screenshot and try to find "US Letter". Can't be selected. Nor A3. This is our office printer.

And this is shot at 1920x1080 and the control-center is moved as much upwards as I could. In 1366x768 (a common resolution for old laptops), I couldn't even see A4.

It was very difficult for me to find a workaround. You can move the selection with keys, but the selected item is not scrolled to be visible, so you have no idea what you're selecting. Mouse wheel doesn't work on the list either. After 20 minutes, I found out that you can use the mouse wheel on the *closed list* and that allows you to select even invisible items.

Comment 5 Kamil Páral 2022-03-29 10:40:56 UTC
Created attachment 1868939 [details]
screenshot of cropped paper type

This is cropped paper type menu at 1360x768 resolution. There should be 19 items in the menu.

Comment 6 Kamil Páral 2022-03-29 10:46:24 UTC
Proposing as a Final blocker due to GNOME Settings not providing basic functionality when it comes to adding and configuring a new printer (e.g. setting paper size and paper type):
https://fedoraproject.org/wiki/Fedora_36_Final_Release_Criteria#Default_application_functionality

Please note that printing itself seems to not be affected if you use the system print dialog (e.g. from evince). In that print dialog, all options are available and menu items can be scrolled. The problem is that you can't configure the defaults in GNOME Settings, or perhaps some additional options not exposed in the print dialog.

Comment 7 Brandon Nielsen 2022-03-29 18:57:06 UTC
Pretty sure none of the lists are really ordered in any meaningful way, just however the relevant PPD orders them.

As for the workaround, as mentioned in comment 2 and comment 4, you can scroll the lists by hovering over them and using the mouse wheel, otherwise <TAB> until what you need to change in highlighted, then arrow keys. Or you can configure the options through the CUPS web interface at localhost:631.

I did a grep on the gnome-control-center code base for other GtkComboBox instances that may bite us that have yet gone unnoticed. The only one I see is the sound device selection and sound device profile selection combo boxes. On a machine with a lot of sound devices, or a device supporting many different profiles, those could pretty easily grow to have devices or profiles that aren't easily selectable. For those, the mouse wheel trick doesn't seem to work. You can <TAB> to them.

The rest seem bounded to a displayable number of items.

Comment 8 Lukas Ruzicka 2022-03-31 11:16:13 UTC
I have 5 sound devices on my computer and tried to take a look in Gnome-Control-Center and I can see all these records. 
As you can see on the screenshots, the Input combo takes easily 12 items. Unfortunately I do not have any other devices to connect, but I believe it would be able to show them if I had.

Comment 9 Lukas Ruzicka 2022-03-31 11:17:25 UTC
Created attachment 1869683 [details]
Listed input devices

Comment 10 Lukas Ruzicka 2022-03-31 11:18:03 UTC
Created attachment 1869684 [details]
Listed output devices

Comment 11 Brandon Nielsen 2022-03-31 18:21:17 UTC
With a bit of playing about with likely uncommon resolutions and number of input devices (faked 15 in VM), I can confirm it does show the issue. I wouldn't block on it, but I might raise it upstream. I'll attach a screenshot.

I would argue it's actually more broken because you can't use the scroll wheel like you might expect.

Comment 12 Brandon Nielsen 2022-03-31 18:22:02 UTC
Created attachment 1869782 [details]
Low resolution, high number of outputs, broken selection box

Comment 13 Brandon Nielsen 2022-03-31 18:28:26 UTC
Created attachment 1869783 [details]
Low resolution, buggy popup behavior, no scroll possible

Another example. The popup chooses a bad location, effectively making the combo box useless.

You could argue the resolution isn't realistic, but GNOME purports itself to be responsive. And if you could scroll the box it would only be awkward to use, not useless.

Comment 14 Kamil Páral 2022-04-04 07:27:13 UTC
(In reply to Kamil Páral from comment #6)
> Proposing as a Final blocker

Another real-world example is here. The user can't select neither A4 nor US Letter. It's also not obvious that there more more options hidden:
https://ask.fedoraproject.org/t/truncated-and-unselectable-printer-media-size-options-on-fedora-36/21046

Comment 15 František Zatloukal 2022-04-04 19:13:09 UTC
Discussed during the 2022-04-04 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made:

This is accepted as a conditional violation of the following Beta criterion: “Printing must work in release-blocking desktops on at least one printer available to those performing validation testing.”

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2022-04-04/f36-blocker-review.2022-04-04-16.00.log.html

Comment 16 Fedora Update System 2022-04-06 13:34:39 UTC
FEDORA-2022-ec2cc0b378 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-ec2cc0b378

Comment 17 Kamil Páral 2022-04-06 15:10:41 UTC
(In reply to Fedora Update System from comment #16)
> FEDORA-2022-ec2cc0b378 has been submitted as an update to Fedora 36.
> https://bodhi.fedoraproject.org/updates/FEDORA-2022-ec2cc0b378

The printer options drop-downs can now be scrolled, great.

Comment 18 Fedora Update System 2022-04-06 17:55:56 UTC
FEDORA-2022-ec2cc0b378 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-ec2cc0b378`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-ec2cc0b378

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 19 Fedora Update System 2022-04-08 02:57:03 UTC
FEDORA-2022-ec2cc0b378 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.