Bug 2063483 - SELinux is preventing blueman-mechani from 'write' accesses on the file /memfd:libffi (deleted).
Summary: SELinux is preventing blueman-mechani from 'write' accesses on the file /memf...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 36
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ab521dfca63004711099900a72b...
: 2068874 2083978 2085096 2096254 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-03-13 02:57 UTC by Ian Laurie
Modified: 2022-07-23 09:27 UTC (History)
14 users (show)

Fixed In Version: selinux-policy-36.9-1.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-28 01:14:48 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github fedora-selinux selinux-policy pull 1168 0 None open Allow blueman read/write its private memfd: objects 2022-04-26 15:17:37 UTC
Github fedora-selinux selinux-policy pull 1175 0 None Merged Allow blueman map its private memfd: files 2022-05-10 12:39:55 UTC

Description Ian Laurie 2022-03-13 02:57:19 UTC
Description of problem:
Just login to new install from Fedora-Cinnamon-Live-x86_64-36_Beta-1.1.iso.
SELinux is preventing blueman-mechani from 'write' accesses on the file /memfd:libffi (deleted).

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that blueman-mechani should be allowed write access on the memfd:libffi (deleted) file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'blueman-mechani' --raw | audit2allow -M my-bluemanmechani
# semodule -X 300 -i my-bluemanmechani.pp

Additional Information:
Source Context                system_u:system_r:blueman_t:s0
Target Context                system_u:object_r:tmpfs_t:s0
Target Objects                /memfd:libffi (deleted) [ file ]
Source                        blueman-mechani
Source Path                   blueman-mechani
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
SELinux Policy RPM            selinux-policy-targeted-36.3-1.fc36.noarch
Local Policy RPM              selinux-policy-targeted-36.3-1.fc36.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 5.17.0-0.rc7.116.fc36.x86_64 #1
                              SMP PREEMPT Mon Mar 7 23:10:19 UTC 2022 x86_64
                              x86_64
Alert Count                   3
First Seen                    2022-03-13 13:55:51 AEDT
Last Seen                     2022-03-13 13:55:51 AEDT
Local ID                      c4ee1ede-f6b1-4f81-80b8-3b8d8ccc0015

Raw Audit Messages
type=AVC msg=audit(1647140151.68:372): avc:  denied  { write } for  pid=1925 comm="blueman-mechani" path=2F6D656D66643A6C6962666669202864656C6574656429 dev="tmpfs" ino=1064 scontext=system_u:system_r:blueman_t:s0 tcontext=system_u:object_r:tmpfs_t:s0 tclass=file permissive=0


Hash: blueman-mechani,blueman_t,tmpfs_t,file,write

Version-Release number of selected component:
selinux-policy-targeted-36.3-1.fc36.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.17.0
hashmarkername: setroubleshoot
kernel:         5.17.0-0.rc7.116.fc36.x86_64
type:           libreport

Comment 1 Milos Malik 2022-03-16 15:47:49 UTC
Following SELinux denials appears 3 times in enforcing mode:
----
type=PROCTITLE msg=audit(03/16/2022 11:43:58.454:603) : proctitle=/usr/bin/python3 /usr/libexec/blueman-mechanism 
type=SYSCALL msg=audit(03/16/2022 11:43:58.454:603) : arch=x86_64 syscall=write success=no exit=EACCES(Permission denied) a0=0x9 a1=0x7ffce19481c0 a2=0x1000 a3=0x1000 items=0 ppid=1 pid=1952 auid=unset uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=unset comm=blueman-mechani exe=/usr/bin/python3.10 subj=system_u:system_r:blueman_t:s0 key=(null) 
type=AVC msg=audit(03/16/2022 11:43:58.454:603) : avc:  denied  { write } for  pid=1952 comm=blueman-mechani path=/memfd:libffi (deleted) dev="tmpfs" ino=20 scontext=system_u:system_r:blueman_t:s0 tcontext=system_u:object_r:tmpfs_t:s0 tclass=file permissive=0 
----

# rpm -qa selinux\* blueman\* | sort
blueman-2.2.4-1.fc36.x86_64
selinux-policy-36.2-1.fc37.noarch
selinux-policy-targeted-36.2-1.fc37.noarch
#

Comment 3 Milos Malik 2022-03-16 15:51:35 UTC
Following SELinux denials appeared in permissive mode:
----
type=PROCTITLE msg=audit(03/16/2022 11:49:19.370:611) : proctitle=/usr/bin/python3 /usr/libexec/blueman-mechanism 
type=SYSCALL msg=audit(03/16/2022 11:49:19.370:611) : arch=x86_64 syscall=write success=yes exit=4096 a0=0x9 a1=0x7ffdefa7e920 a2=0x1000 a3=0x1000 items=0 ppid=1 pid=2018 auid=unset uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=unset comm=blueman-mechani exe=/usr/bin/python3.10 subj=system_u:system_r:blueman_t:s0 key=(null) 
type=AVC msg=audit(03/16/2022 11:49:19.370:611) : avc:  denied  { write } for  pid=2018 comm=blueman-mechani path=/memfd:libffi (deleted) dev="tmpfs" ino=21 scontext=system_u:system_r:blueman_t:s0 tcontext=system_u:object_r:tmpfs_t:s0 tclass=file permissive=1 
----
type=PROCTITLE msg=audit(03/16/2022 11:49:19.372:612) : proctitle=/usr/bin/python3 /usr/libexec/blueman-mechanism 
type=MMAP msg=audit(03/16/2022 11:49:19.372:612) : fd=9 flags=MAP_SHARED 
type=SYSCALL msg=audit(03/16/2022 11:49:19.372:612) : arch=x86_64 syscall=mmap success=yes exit=139770795438080 a0=0x0 a1=0x1000 a2=PROT_READ|PROT_EXEC a3=MAP_SHARED items=0 ppid=1 pid=2018 auid=unset uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=unset comm=blueman-mechani exe=/usr/bin/python3.10 subj=system_u:system_r:blueman_t:s0 key=(null) 
type=AVC msg=audit(03/16/2022 11:49:19.372:612) : avc:  denied  { read execute } for  pid=2018 comm=blueman-mechani path=/memfd:libffi (deleted) dev="tmpfs" ino=21 scontext=system_u:system_r:blueman_t:s0 tcontext=system_u:object_r:tmpfs_t:s0 tclass=file permissive=1 
type=AVC msg=audit(03/16/2022 11:49:19.372:612) : avc:  denied  { map } for  pid=2018 comm=blueman-mechani path=/memfd:libffi (deleted) dev="tmpfs" ino=21 scontext=system_u:system_r:blueman_t:s0 tcontext=system_u:object_r:tmpfs_t:s0 tclass=file permissive=1 
----

The "could not allocate closure" message (visible in previous comment) does not appear in permissive mode.

Comment 5 Abhisek Mukherjee 2022-03-17 15:54:42 UTC
Similar problem has been detected:

Fresh login into Fedora Cinnamon

hashmarkername: setroubleshoot
kernel:         5.17.0-0.rc7.116.fc36.x86_64
package:        selinux-policy-targeted-36.3-1.fc36.noarch
reason:         SELinux is preventing blueman-mechani from 'write' accesses on the file /memfd:libffi (deleted).
type:           libreport

Comment 6 Abhisek Mukherjee 2022-03-17 15:59:33 UTC
SELinux is preventing blueman-mechani from write access on the file /memfd:libffi (deleted).

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that blueman-mechani should be allowed write access on the memfd:libffi (deleted) file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'blueman-mechani' --raw | audit2allow -M my-bluemanmechani
# semodule -X 300 -i my-bluemanmechani.pp

Additional Information:
Source Context                system_u:system_r:blueman_t:s0
Target Context                system_u:object_r:tmpfs_t:s0
Target Objects                /memfd:libffi (deleted) [ file ]
Source                        blueman-mechani
Source Path                   blueman-mechani
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
SELinux Policy RPM            selinux-policy-targeted-36.3-1.fc36.noarch
Local Policy RPM              selinux-policy-targeted-36.3-1.fc36.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux Karma-X 5.17.0-0.rc7.116.fc36.x86_64 #1 SMP
                              PREEMPT Mon Mar 7 23:10:19 UTC 2022 x86_64 x86_64
Alert Count                   15
First Seen                    2022-03-17 12:02:07 IST
Last Seen                     2022-03-17 21:15:16 IST
Local ID                      c34fae49-f33e-4115-8487-91c32976cda9

Raw Audit Messages
type=AVC msg=audit(1647531916.71:256): avc:  denied  { write } for  pid=1982 comm="blueman-mechani" path=2F6D656D66643A6C6962666669202864656C6574656429 dev="tmpfs" ino=10243 scontext=system_u:system_r:blueman_t:s0 tcontext=system_u:object_r:tmpfs_t:s0 tclass=file permissive=0


Hash: blueman-mechani,blueman_t,tmpfs_t,file,write

Comment 7 Budhaditya Saha 2022-03-18 06:38:39 UTC
Similar problem has been detected:

Default installation SE Linux prompt.

hashmarkername: setroubleshoot
kernel:         5.17.0-0.rc7.116.fc36.x86_64
package:        selinux-policy-targeted-36.3-1.fc36.noarch
reason:         SELinux is preventing blueman-mechani from 'write' accesses on the file /memfd:libffi (deleted).
type:           libreport

Comment 8 Budhaditya Saha 2022-03-22 03:49:03 UTC
Similar problem has been detected:

on startup

hashmarkername: setroubleshoot
kernel:         5.17.0-0.rc7.116.fc36.x86_64
package:        selinux-policy-targeted-36.5-1.fc36.noarch
reason:         SELinux is preventing blueman-mechani from 'write' accesses on the file /memfd:libffi (deleted).
type:           libreport

Comment 9 Zdenek Pytela 2022-03-28 15:30:51 UTC
*** Bug 2068874 has been marked as a duplicate of this bug. ***

Comment 10 Sergei S. Rublёv 2022-04-01 17:27:30 UTC
Similar problem has been detected:

Every time Fedora starts

hashmarkername: setroubleshoot
kernel:         5.17.1-300.fc36.x86_64
package:        selinux-policy-targeted-36.5-1.fc36.noarch
reason:         SELinux is preventing blueman-mechani from 'write' accesses on the file /memfd:libffi (deleted).
type:           libreport

Comment 11 Ian Laurie 2022-04-03 04:12:27 UTC
Similar problem has been detected:

Booted Fedora and logged into Cinnamon.

hashmarkername: setroubleshoot
kernel:         5.17.1-300.fc36.x86_64
package:        selinux-policy-targeted-36.5-1.fc36.noarch
reason:         SELinux is preventing blueman-mechani from 'write' accesses on the file /memfd:libffi (deleted).
type:           libreport

Comment 12 Riccardo Pittau 2022-04-05 17:54:22 UTC
Similar problem has been detected:

starting Fedora 36 beta

hashmarkername: setroubleshoot
kernel:         5.17.1-300.fc36.x86_64
package:        selinux-policy-targeted-36.5-1.fc36.noarch
reason:         SELinux is preventing blueman-mechani from 'write' accesses on the file /memfd:libffi (deleted).
type:           libreport

Comment 13 Pantelis Bischitzis 2022-04-11 08:41:49 UTC
Similar problem has been detected:

I just booted for the first tiime after installation and the first alert i got was this.

hashmarkername: setroubleshoot
kernel:         5.17.0-0.rc7.116.fc36.x86_64
package:        selinux-policy-targeted-36.5-1.fc36.noarch
reason:         SELinux is preventing blueman-mechani from 'write' accesses on the file /memfd:libffi (deleted).
type:           libreport

Comment 14 Dan Kendall 2022-04-14 15:07:21 UTC
Similar problem has been detected:

On login

hashmarkername: setroubleshoot
kernel:         5.17.2-300.fc36.x86_64
package:        selinux-policy-targeted-36.6-1.fc36.noarch
reason:         SELinux is preventing blueman-mechani from 'write' accesses on the file /memfd:libffi (deleted).
type:           libreport

Comment 15 David Haines 2022-04-21 13:31:05 UTC
Similar problem has been detected:

Just logged into my Cinnamon desktop; denial notification appeared immediately.

hashmarkername: setroubleshoot
kernel:         5.17.3-302.fc36.x86_64
package:        selinux-policy-targeted-36.6-1.fc36.noarch
reason:         SELinux is preventing blueman-mechani from 'write' accesses on the file /memfd:libffi (deleted).
type:           libreport

Comment 16 laolux 2022-05-06 02:39:18 UTC
Similar problem has been detected:

Problem suddenly appeared after upgrading from Fedora 35 to Fedora 36.
I don't know what the consequences are besides getting an selinux alert.
Bluetooth headphones still work, so maybe this is a spurious message?

hashmarkername: setroubleshoot
kernel:         5.17.5-300.fc36.x86_64
package:        selinux-policy-targeted-36.8-1.fc36.noarch
reason:         SELinux is preventing blueman-mechani from 'write' accesses on the file /memfd:libffi (deleted).
type:           libreport

Comment 17 Zdenek Pytela 2022-05-11 07:40:55 UTC
*** Bug 2083978 has been marked as a duplicate of this bug. ***

Comment 18 Joel Hager 2022-05-12 19:19:04 UTC
*** Bug 2085096 has been marked as a duplicate of this bug. ***

Comment 19 christopher 2022-05-13 18:45:50 UTC
Similar problem has been detected:

Fresh install of Fedora on VirtualBox VM. Installed Cinnamon. Logged out, changed to Cinnamon. Logged in, got this error.

hashmarkername: setroubleshoot
kernel:         5.17.6-300.fc36.x86_64
package:        selinux-policy-targeted-36.8-2.fc36.noarch
reason:         SELinux is preventing blueman-mechani from 'write' accesses on the file /memfd:libffi (deleted).
type:           libreport

Comment 20 plenus 2022-05-17 14:15:50 UTC
Similar problem has been detected:

Right after installing Fedora 36 Cinnamon Spin it was the first thing that came up, right after login into the DE.

hashmarkername: setroubleshoot
kernel:         5.17.5-300.fc36.x86_64
package:        selinux-policy-targeted-36.7-1.fc36.noarch
reason:         SELinux is preventing blueman-mechani from 'write' accesses on the file /memfd:libffi (deleted).
type:           libreport

Comment 21 static.revoided 2022-05-18 17:19:44 UTC
Similar problem has been detected:

Upgrade Fedora from 35 to 36

hashmarkername: setroubleshoot
kernel:         5.17.6-300.fc36.x86_64
package:        selinux-policy-targeted-36.7-1.fc36.noarch
reason:         SELinux is preventing blueman-mechani from read, execute access on the file /memfd:libffi (deleted).
type:           libreport

Comment 22 Fedora Update System 2022-05-19 16:24:29 UTC
FEDORA-2022-148223ef3b has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-148223ef3b

Comment 23 Fedora Update System 2022-05-20 02:54:41 UTC
FEDORA-2022-148223ef3b has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-148223ef3b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-148223ef3b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 24 Scott Beamer 2022-05-27 02:00:29 UTC
Similar problem has been detected:

Error message popl up on logiin.

hashmarkername: setroubleshoot
kernel:         5.17.9-300.fc36.x86_64
package:        selinux-policy-targeted-36.8-2.fc36.noarch
reason:         SELinux is preventing blueman-mechani from 'write' accesses on the file /memfd:libffi (deleted).
type:           libreport

Comment 25 Fedora Update System 2022-05-28 01:14:48 UTC
FEDORA-2022-148223ef3b has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 26 Volkan GÜZEL 2022-06-13 11:42:52 UTC
*** Bug 2096254 has been marked as a duplicate of this bug. ***

Comment 27 Peter Cherdron 2022-07-23 09:27:28 UTC
Similar problem has been detected:

Direkt nach der Installation. Beim ersten Start des Systems ,

hashmarkername: setroubleshoot
kernel:         5.17.5-300.fc36.x86_64
package:        selinux-policy-targeted-36.7-1.fc36.noarch
reason:         SELinux is preventing blueman-mechani from 'write' accesses on the Datei /memfd:libffi (deleted).
type:           libreport


Note You need to log in before you can comment on or make changes to this bug.