Bug 206349 - IMAP folders inconsistent, crash on changing subscriptions
IMAP folders inconsistent, crash on changing subscriptions
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-13 16:03 EDT by James
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-24 17:49:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debug information (11.29 KB, text/plain)
2006-09-13 16:03 EDT, James
no flags Details
Backtrace of same issue with debuginfo. (9.50 KB, text/plain)
2006-09-13 17:08 EDT, James
no flags Details

  None (edit)
Description James 2006-09-13 16:03:46 EDT
Description of problem:
I have several IMAP folders listed in the Mail pane to which I am not
subscribed, so the subscription system is already inconsistent. I
unsubscribe them in Folder Subscriptions by checking, then unchecking.
On certain folders, this results in a crash.

Version-Release number of selected component (if applicable):
evolution-2.6.3-1.fc5.5

How reproducible:
Always, eventually.

Steps to Reproduce:
1. Open Folder Subscriptions.
2. Check a folder which shouldn't be there but is.
3. Uncheck it.
4. Repeat until crash.
  
Actual results:
Crash.

Expected results:
No crash.
Subscriptions consistent to begin with.

Debug info attached.
Comment 1 James 2006-09-13 16:03:46 EDT
Created attachment 136201 [details]
Debug information
Comment 2 Matthew Barnes 2006-09-13 16:44:15 EDT
Thanks for the bug report.  (And thanks for attaching the backtrace rather than
pasting it inline!)

Can I have you install a few debuginfo packages so that the backtrace shows more
information?  Please install the following packages and attach another backtrace
the next time you experience this crash:

evolution-debuginfo
evolution-data-server-debuginfo
Comment 3 James 2006-09-13 17:08:18 EDT
Created attachment 136210 [details]
Backtrace of same issue with debuginfo.
Comment 4 Matthew Barnes 2006-09-13 17:11:48 EDT
Thanks, looks like Thread 1 is the culprit.
Comment 5 Matthew Barnes 2006-10-25 12:54:52 EDT
As of yesterday, Evolution 2.6 is no longer supported in Fedora Core 5.
Can you please try again with Evolution 2.8 in Fedora Core 6?
Comment 6 James 2006-11-24 17:49:42 EST
Hello. Sorry for the long silence. I've not seen the problem so far in FC6, so
I'm closing here. Thanks.

Note You need to log in before you can comment on or make changes to this bug.