Bug 2063588 - weechat-3.5 is available
Summary: weechat-3.5 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: weechat
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paul P Komkoff Jr
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-03-13 23:47 UTC by Upstream Release Monitoring
Modified: 2022-06-01 01:26 UTC (History)
6 users (show)

Fixed In Version: weechat-3.5-2.fc34 weechat-3.5-2.fc36 weechat-3.5-2.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-06-01 01:05:59 UTC
Type: ---


Attachments (Terms of Use)
Update to 3.5 (#2063588) (622 bytes, patch)
2022-03-27 18:46 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2022-03-13 23:47:54 UTC
Latest upstream release: 3.4.1
Current version/release in rawhide: 3.4-5.fc36
URL: http://weechat.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/5122/

Comment 1 Upstream Release Monitoring 2022-03-13 23:48:00 UTC
Scratch build failed. Details bellow:

GenericError: File upload failed: cli-build/1647215279.0437467.niXhQQwH/weechat-3.4.1-1.fc34.src.rpm
Traceback:
  File "/usr/local/lib/python3.9/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.9/site-packages/hotness/builders/koji.py", line 198, in build
    output["build_id"] = self._scratch_build(session, package.name, srpm)
  File "/usr/local/lib/python3.9/site-packages/hotness/builders/koji.py", line 451, in _scratch_build
    session.uploadWrapper(source, serverdir)
  File "/usr/lib/python3.9/site-packages/koji/__init__.py", line 3027, in uploadWrapper
    self.fastUpload(localfile, path, name, callback, blocksize, overwrite, volume=volume)
  File "/usr/lib/python3.9/site-packages/koji/__init__.py", line 2962, in fastUpload
    raise GenericError("File upload failed: %s/%s" % (path, name))

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 2 Upstream Release Monitoring 2022-03-20 23:54:04 UTC
Latest upstream release: 3.5-rc1
Current version/release in rawhide: 3.4-5.fc36
URL: http://weechat.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/5122/

Comment 3 Upstream Release Monitoring 2022-03-20 23:54:08 UTC
Scratch build failed. Details bellow:

BuilderException: Build started, but failure happened during post build operations:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-41phmu8h/weechat.spec']' returned non-zero exit status 1.

StdOut:
error: Bad source: ./weechat-3.5.tar.xz: No such file or directory


Traceback:
  File "/usr/local/lib/python3.9/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.9/site-packages/hotness/builders/koji.py", line 188, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 4 Upstream Release Monitoring 2022-03-27 18:46:26 UTC
Latest upstream release: 3.5
Current version/release in rawhide: 3.4-5.fc36
URL: http://weechat.org/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/5122/

Comment 5 Upstream Release Monitoring 2022-03-27 18:46:31 UTC
Created attachment 1868551 [details]
Update to 3.5 (#2063588)

Comment 6 Upstream Release Monitoring 2022-03-27 18:53:18 UTC
the-new-hotness/release-monitoring.org's scratch build of weechat-3.5-1.fc34.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=84801590

Comment 7 Michel Alexandre Salim 2022-03-29 18:43:44 UTC
Looks like release monitoring should be updated to exclude pre-releases

Comment 8 Fedora Update System 2022-05-23 20:41:43 UTC
FEDORA-2022-6e226a21ed has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2022-6e226a21ed

Comment 9 Fedora Update System 2022-05-23 20:41:44 UTC
FEDORA-2022-d165104234 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-d165104234

Comment 10 Fedora Update System 2022-05-23 20:41:45 UTC
FEDORA-2022-127b6e8a95 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-127b6e8a95

Comment 11 Fedora Update System 2022-05-24 01:13:55 UTC
FEDORA-2022-d165104234 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-d165104234`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-d165104234

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2022-05-24 01:15:55 UTC
FEDORA-2022-127b6e8a95 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-127b6e8a95`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-127b6e8a95

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2022-05-24 02:05:26 UTC
FEDORA-2022-6e226a21ed has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-6e226a21ed`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-6e226a21ed

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2022-06-01 01:05:59 UTC
FEDORA-2022-6e226a21ed has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 15 Fedora Update System 2022-06-01 01:24:09 UTC
FEDORA-2022-d165104234 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 16 Fedora Update System 2022-06-01 01:26:00 UTC
FEDORA-2022-127b6e8a95 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.