Bug 206393 - kernel BUG at fs/jbd/checkpoint.c
kernel BUG at fs/jbd/checkpoint.c
Status: CLOSED DUPLICATE of bug 205610
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Eric Sandeen
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-09-13 23:47 EDT by Cedric Tardif
Modified: 2007-11-16 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-03 11:19:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Cedric Tardif 2006-09-13 23:47:54 EDT
Kernel panic server as to be restarted.

Kernel version : 
Linux aphrodite.videodery.qc.ca 2.6.9-42.0.2.ELsmp #1 SMP Thu Aug 17 18:00:32
EDT 2006 i686 i686 i386 GNU/Linux

There is the kernel panic :

Assertion failure in log_do_checkpoint() at fs/jbd/checkpoint.c:363: "drop_count
!= 0 || cleanup_ret != 0"
------------[ cut here ]------------
kernel BUG at fs/jbd/checkpoint.c:363!
invalid operand: 0000 [#1]
Modules linked in: iptable_filter ip_tables md5 ipv6 autofs4 sunrpc microcode
dm_mod button battery ac uhci_hcd
CPU:    1
EIP:    0060:[<f8833fc0>]    Not tainted VLI
EFLAGS: 00010216   (2.6.9-42.0.2.ELsmp) 
EIP is at log_do_checkpoint+0x10e/0x148 [jbd]
eax: 0000006e   ebx: c55b80ec   ecx: f71bcb90   edx: f8837dac
esi: c2228a00   edi: f1f8e900   ebp: c55b80ec   esp: f71bcb8c
ds: 007b   es: 007b   ss: 0068
Process syslogd (pid: 2494, threadinfo=f71bc000 task=f6890db0)
Stack: f8837dac f8836f61 f8837d98 0000016b f8837e67 09e9ede5 c55b80ec 00000000
       00000000 00000246 00000000 caa1ed48 005b800a f71bcbc8 c02d2d6a f6450d80
       c015d271 00001000 c2213400 ec7f3454 00000001 d08bd320 f88933e2 ec7f3454
Call Trace:
 [<c02d2d6a>] __cond_resched+0x14/0x39
 [<c015d271>] __getblk+0x2b/0x49
 [<f88933e2>] ext3_get_inode_loc+0x4f/0x226 [ext3]
 [<f8893c03>] ext3_do_update_inode+0x2f7/0x31e [ext3]
 [<f8830d1c>] journal_get_write_access+0x25/0x2c [jbd]
 [<c0143016>] mempool_alloc+0x7b/0x135
 [<f8831f01>] __journal_file_buffer+0x147/0x221 [jbd]
 [<f8830cdb>] do_get_write_access+0x516/0x532 [jbd]  
 [<f8831f01>] __journal_file_buffer+0x147/0x221 [jbd]
 [<f8833b7c>] __log_wait_for_space+0xbb/0xe5 [jbd]   
 [<f883037e>] start_this_handle+0x2e4/0x32a [jbd]    
 [<f8893eb6>] ext3_mark_iloc_dirty+0x10/0x18 [ext3]  
 [<c027cfed>] memcpy_toiovec+0x5f/0x88
 [<c02d2d6a>] __cond_resched+0x14/0x39
 [<f883047c>] journal_start+0x78/0x9e [jbd]
 [<f8891d73>] ext3_prepare_write+0x32/0xf5 [ext3]
 [<c014212e>] generic_file_buffered_write+0x1e9/0x501
 [<c01a9f5f>] avc_has_perm_noaudit+0x8d/0xda
 [<c01268d8>] current_fs_time+0x44/0x4c
 [<c01427cf>] __generic_file_aio_write_nolock+0x389/0x3b7
 [<c0142900>] __generic_file_write_nolock+0x84/0x99
 [<c0279249>] sys_recvfrom+0xe6/0xf5
 [<c01acd4e>] selinux_file_permission+0x117/0x120
 [<c01204f5>] autoremove_wake_function+0x0/0x2d  
 [<c0142c10>] generic_file_writev+0x4f/0xac
 [<c0142bc1>] generic_file_writev+0x0/0xac 
 [<c015b450>] do_readv_writev+0x1c5/0x245  
 [<c015af3d>] do_sync_write+0x0/0xc9
 [<c0279953>] sys_socketcall+0x17b/0x1fb
 [<c015b54e>] vfs_writev+0x3e/0x43
 [<c015b5f1>] sys_writev+0x3c/0x62
 [<c02d47bf>] syscall_call+0x7/0xb
Code: 89 f0 e8 4f fc ff ff 0b 44 24 0c 75 29 68 67 7e 83 f8 68 6b 01 00 00 68 98
7d 83 f8 68 61 6f 83 f8 68 ac
 <0>Fatal exception: panic in 5 seconds
Kernel panic - not syncing: Fatal exception
Comment 2 Eric Sandeen 2006-10-03 11:19:26 EDT

*** This bug has been marked as a duplicate of 205610 ***

Note You need to log in before you can comment on or make changes to this bug.