Bug 2064117 (CVE-2022-0985, MSA-22-0006) - CVE-2022-0985 moodle: Users with moodle/site:uploadusers but without moodle/user:delete could delete users
Summary: CVE-2022-0985 moodle: Users with moodle/site:uploadusers but without moodle/u...
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2022-0985, MSA-22-0006
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 2064121 2064123
Blocks: 2064218
TreeView+ depends on / blocked
 
Reported: 2022-03-15 06:13 UTC by TEJ RATHI
Modified: 2022-04-28 16:39 UTC (History)
3 users (show)

Fixed In Version: moodle 3.11.6, moodle 3.10.10, moodle 3.9.13
Doc Type: If docs needed, set a value
Doc Text:
Insufficient capability checks could allow users with the moodle/site:uploadusers capability to delete users, without having the necessary moodle/user:delete capability.
Clone Of:
Environment:
Last Closed: 2022-03-15 10:01:26 UTC


Attachments (Terms of Use)

Description TEJ RATHI 2022-03-15 06:13:45 UTC
Insufficient capability checks could allow users with the moodle/site:uploadusers capability to delete users, without
having the necessary moodle/user:delete capability.

Versions affected: 3.11 to 3.11.5, 3.10 to 3.10.9, 3.9 to 3.9.12 and earlier unsupported versions

References:
http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-72972

Comment 1 TEJ RATHI 2022-03-15 06:14:18 UTC
Created moodle tracking bugs for this issue:

Affects: epel-7 [bug 2064121]
Affects: fedora-all [bug 2064123]

Comment 3 Product Security DevOps Team 2022-03-15 10:01:24 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.