Bug 2064192 - Anaconda cannot report crashes to Bugzilla.
Summary: Anaconda cannot report crashes to Bugzilla.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreport
Version: 36
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: abrt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F36BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2022-03-15 09:36 UTC by Lukas Ruzicka
Modified: 2022-03-17 01:38 UTC (History)
15 users (show)

Fixed In Version: libreport-2.17.1-1.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-03-17 01:38:48 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
The error message shown by Anaconda. (21.83 KB, image/png)
2022-03-15 10:17 UTC, Lukas Ruzicka
no flags Details

Description Lukas Ruzicka 2022-03-15 09:36:13 UTC
Description of problem:

On Fedora 36 Beta RC, Anaconda is unable to report crashes to Bugzilla. The process ends up with the following error:

--- Running report_Bugzilla ---
Checking for duplicates
fatal: Unable to make sense of XML-RPC response from server.  Invalid struct for <fault> value.  Invalid value for 'faultCode' member.  Value of type STRING supplied where type INT was expected..  Use XMLRPC_TRACE_XML to see for yourself
('report_Bugzilla' exited with 1)

Version-Release number of selected component (if applicable):
anaconda-36.16.2-2.fc36.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Start the RC beta Live ISO
2. Start Anaconda, do some stuff and start the installation.
3. Crash it using the command: kill -USR1 `cat /var/run/anaconda.pid`
4. Use the built-in reporter to have report it.
5. Also, have you Bugzilla API_KEY ready, since you will not be able to send it without it.

Actual results:

A crash is impossible to report.

Expected results:

It should possible to report crashes.

Comment 1 Fedora Blocker Bugs Application 2022-03-15 09:44:55 UTC
Proposed as a Blocker for 36-beta by Fedora user lruzicka using the blocker tracking app because:

 This violates the Failure reporting criteria

https://fedoraproject.org/wiki/Basic_Release_Criteria#Failure_reporting

Comment 2 Lukas Ruzicka 2022-03-15 10:13:06 UTC
Same is happening with the textual version of Anaconda.
See screenshot.

Comment 3 Lukas Ruzicka 2022-03-15 10:17:26 UTC
Created attachment 1865995 [details]
The error message shown by Anaconda.

The screenshot of the bug reporting process showing the error in Anaconda's text regime.

Comment 4 Lukas Ruzicka 2022-03-15 12:01:56 UTC
The update testing libreport (libreport-2.17.1-1.fc36.x86_64) fixes this.

Comment 5 Fedora Update System 2022-03-15 13:17:55 UTC
FEDORA-2022-eb9a49a622 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-eb9a49a622

Comment 6 Adam Williamson 2022-03-15 15:40:18 UTC
+5 in https://pagure.io/fedora-qa/blocker-review/issue/669 , marking accepted.

Comment 7 Fedora Update System 2022-03-17 01:38:48 UTC
FEDORA-2022-eb9a49a622 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.