Bug 20643 - in.tftpd from tftp-server-0.17-5 package does not respond to WRQ properly
in.tftpd from tftp-server-0.17-5 package does not respond to WRQ properly
Status: CLOSED DUPLICATE of bug 18128
Product: Red Hat Linux
Classification: Retired
Component: tftp (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-10 09:44 EST by Ben Cohen Jr
Modified: 2014-03-16 22:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-10 09:44:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Cohen Jr 2000-11-10 09:44:20 EST
I recently installed RedHat Linux 7.0 and included the tftp-server-0.17-5 package during install.  When I tried to put a file to the server from either 
a Windows NT 4 client or a RedHat Linux 7 client I receive "request timed out".  After activating the verbose and trace options on the client as 
well as throwing a sniffer on the line I saw that the server was responding to the WRQ packet with an ACK packet for block 1.  According to 
RFC1350, the server should respond to WRQ with an ACK for block 0.  After that the client will send DATA packets starting with block 1 and 
expect ACKs for each of those blocks.  I verified that this is the proper behavior by putting a file to a RedHat Linux 6.1 box with the tftp-0.15-1 
package installed and it indeed does send an ACK for block 0 in response to a WRQ.  I queried for any bugs relating to this and could not find 
one so I am submitting this one.  If you need more information, please email me at bcohenjr@visto.com.

Thanks,
Ben Cohen Jr.
Comment 1 Pekka Savola 2000-11-11 09:48:46 EST

*** This bug has been marked as a duplicate of 18128 ***

Note You need to log in before you can comment on or make changes to this bug.