Bug 2064454 - Topology performance: Immutable .toJSON consumes a lot of CPU time when rendering a large topology graph (~100 nodes)
Summary: Topology performance: Immutable .toJSON consumes a lot of CPU time when rende...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.9.z
Assignee: Christoph Jerolimov
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On: 2054757
Blocks: 2066365
TreeView+ depends on / blocked
 
Reported: 2022-03-15 21:41 UTC by Christoph Jerolimov
Modified: 2022-04-13 05:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-04-13 05:10:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 11184 0 None open [release-4.9] Bug 2064454: (Topology) Performance improvement by reducing rerenderings and deep-copy toJSON() calls 2022-03-17 12:09:16 UTC
Github openshift console pull 11256 0 None open Bug 2064454: return process data as array for list true in firehose as done in hooks 2022-03-30 09:08:22 UTC
Red Hat Product Errata RHBA-2022:1245 0 None None None 2022-04-13 05:10:49 UTC

Comment 6 Jaivardhan Kumar 2022-03-30 11:12:52 UTC
*** Bug 2069621 has been marked as a duplicate of this bug. ***

Comment 8 Mohammed Saud 2022-04-05 08:28:15 UTC
Verified on:
Build:    4.9.0-0.nightly-2022-04-04-160205
Browsers: Firefox 98, Chromium 99

Comment 10 Christoph Jerolimov 2022-04-12 09:28:53 UTC
Verified this now also on the release 4.9.28 together with the bugfix https://bugzilla.redhat.com/show_bug.cgi?id=2069621, topology performance is still fine.

Comment 12 errata-xmlrpc 2022-04-13 05:10:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.28 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:1245


Note You need to log in before you can comment on or make changes to this bug.